Lattepanda864S power failure

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
merlin008
Posts: 1
Joined: Thu Apr 02, 2020 2:54 pm

Fri Apr 03, 2020 3:25 pm

image.jpg
image.jpg (1.46 MiB) Viewed 534 times
Please see soldering or lack of on my LattePanda 864S, anyone else with power related issues on their board see the same on the underside on the USB C connector?

User avatar
ccs_hello
Posts: 550
Joined: Sat Oct 13, 2018 9:16 pm

Mon Apr 06, 2020 12:57 pm

Re: bottom-side USB-C connector soldering

Yes, my LP Alpha board looks just like yours and it is working fine.
The top-side soldering appears to be okay and the through-hole PCB makes the bottom-side contacts also working (not ideal but) as well.

User avatar
ccs_hello
Posts: 550
Joined: Sat Oct 13, 2018 9:16 pm

Mon Apr 06, 2020 12:59 pm

BTW, you are in wrong subforum. Next time, pick LP Alpha & Delta subforum. Thx.

Post Reply