LCD not working unless connected AFTER power-up

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 1
    Joined: Sat Feb 23, 2019 5:01 pm

    Sat Feb 23, 2019 5:06 pm

    I bought a 7" LCD for the Latte Panda and if I connect it to the LP before power up it displays only random vertical lines.

    I assumed it was faulty, so a second one arrived (so now I have 2) and both do the same thing.

    If I disconnect the ribbon cable, power up the LP and THEN connect the LCD they both work fine.

    What could the problem be and how can I fix it?

    User avatar
    Posts: 1
    Joined: Mon Jan 07, 2019 4:36 pm

    Tue Mar 19, 2019 9:23 am

    I have exactly the same problem. I had an old display which worked fine. It was bought in 2016 or 2017. Unfortunately the cable broke. Now I bought a new one which has a connection cable that is different from the one I had before. It works fine if I do like you described. After booting I have to open and close the connector. Then it works. It shows grey lines also after the Lattepanda has gone to sleep. My LP 2/32 w windows 10 activated is one of the first they sold. Updating the intel graphics driver did not help. I guess there is a wrong bios setting regarding the power management of the display. Maybe a firmware update of the LP would help. But I won't do this unless they advice me to do so

    User avatar
    Posts: 4
    Joined: Tue Apr 30, 2019 1:07 pm

    Tue Jan 28, 2020 7:42 am

    Same here, but it seems like the lattepanda itself is the problem. Its a massive problem.

    Sometimes the image revives itself, but you'll see pretty bad ghosting on the screen in this case.

    Is there anything to solve this problem?

    User avatar
    Posts: 1
    Joined: Wed Oct 14, 2020 8:36 pm

    Wed Oct 14, 2020 8:44 pm

    Anybody solve this problem?
    I have two screen like that and any of them dont work, board are powered by CN2 pin with 5v 7A power supply. I tried to reset bios, reinstall windows, drivers, nothing helps
    My board is S70CR110-C45B/Z8300

    Post Reply