Page 1 of 1

Problem with HDMI output using KVM switch

Posted: Sun Jan 26, 2020 9:19 pm
by k3dAR
i have LatePanda V1.2 2GB/32GB with Xubuntu 18.04.3 64bit and KVM Aten CS629

after KVM switch to second PC, and back, LattePanda not show video on HDMI output, KVM have "keep video active" mode when switched to other,
but LattePanda switch HDMI output OFF (as i see in xrandr output) while is not active, and not switch back to ON while KVM set back to LattePanda...

workaround is (not always work) to switch using keyboard to virtual console using CTRL+ALT+F1 and back to Desktop using CTRL+ALT+F7,
but problem is not about Xubuntu (or GNU/Linux) General, because while LattePanda is OFF and connected to KVM and switch as active, then after PowerOn LattePanda is bios not initializad, wait 5minutes, then connect from LCD Monitor HDMI cable direct (without KVM) and LattePanda show Logo and start initializing and boot system, then is wait to connected HDMI monitor...

i try many change in BIOS about GPU and PowerSave, reset to default, but nothing help...

Re: Problem with HDMI output using KVM switch

Posted: Sun Jan 26, 2020 9:20 pm
by k3dAR
btw: with Raspberry Pi2, Pi3 or ASUS TinkerBoard, TinkerBoardS not have this problem and switch via KVM Video between SBC and Desktop work without problem

Re: Problem with HDMI output using KVM switch

Posted: Sun Feb 23, 2020 5:41 pm
by k3dAR
about ~month without answer, thanks "support" :roll: ...

no more wait, now i go to sollution(i hope) to buy additional 3rd HW Digitus DA-70466 (for 10% of LatePanda board price...) to fix this stup1d LattePanda problem,,,

Re: Problem with HDMI output using KVM switch

Posted: Tue Feb 25, 2020 8:29 am
by calpin
Hi, so far as I know, the reason of this problem is the Intel chip will set as low power mode when the HDMI port connect with nothing. so a Display Emulator is a easy way to get around this “function“
And if you need a software method, we hope this post can help you.
https://askubuntu.com/questions/453109/ ... plugged-in

Re: Problem with HDMI output using KVM switch

Posted: Tue Feb 25, 2020 4:15 pm
by k3dAR
thanks :-) but:
- second PC on KVM-Switch with LattePanda is STX+i7100T (=with Intel CPU/GPU) and not have problem

- DisplayEmulator/Terminator be sure usable for boot without HDMI connected (or KVM switch to LattePanda Not Active), but i need connected HDMI output as LattePanda is primary use as Kodi player

- using xorg dummy video driver i know and use on servers (without LCD connected for VNC access) many years, but too is not sollution for my problem, because for "bios wait for hdmi" not help and for already started xorg on intel too not solve problem with real hdmi output

as i write i hope help DisplayEmulator/Through, tomorrow i receive it and make test...

BTW: before i hoped to some "magic" bios setting combination to disable hdmi "aggresive checking" or "power management"... or change in BIOS update...

Re: Problem with HDMI output using KVM switch

Posted: Wed Feb 26, 2020 11:20 pm
by k3dAR
i can confirm - Digitus DA-70466 fixed problem with HDMI limitation of LattePanda on KVM-Switch, now switching work... finally after 2 months i stop twice a day reconnecting LCD-HDMI cable between LattePanda and KVM-Switch :-)