Unable to use Ubuntu

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 3
    Joined: Wed Feb 12, 2020 9:47 pm

    Tue Mar 03, 2020 9:25 pm

    I downloaded LP's Ubuntu OS version here .

    It starts at the bootup screen but it seems that whichever option I choose, it always ends up booting without installing Ubuntu. It then opens what looks to be the desktop with no menu bar. Whatever I try to do to bring up a menu bar fails - there is no right click, and no response to any keyboard action.

    I am stuck where to begin fixing / how to install a working Ubuntu OS on the LP. Thanks!!!

    User avatar
    Posts: 2
    Joined: Mon Apr 20, 2020 9:32 pm

    Tue Apr 21, 2020 7:27 am


    I can give you my experience, maybe it helps.
    First I installed also the LP linux image, had no problems doing so. But the distro is full of broken packages, e.g. if I wanted to install additional Python libraries it always fails installation due to broken dependent packages, after a while I gave up :roll: ), But everything else worked!
    I overcome it by installing OpenSuse Leap or Ubuntu 18, just the standard distribution, all things work fine :D

    Just one thing if you install Linux (I just think it does not happen in the LP distro, but maybe I forgot...) in reference to your statement: "...looks to be the desktop with no menu bar. Whatever I try to do to bring up a menu bar fails - there is no right click, and no response to any keyboard action."
    Per default the Linux OS uses on LP as primary screen the DSP-1 (MIPI-DSI connection), but I assume you only use your hdmi connection (as most will do). So try to get the mouse cursor visible on your hdmi connected screen, right click and open a new terminal. Then run "xrandr -q" and you should see the "available" displays, the DSP-1 for MIPI-DSI (even if none connected) and your HDMI screen (in my case it was called HDMI-2). To activate HDMI screen use command "xrandr --output HDMI-2 --auto" (in my case it is HDMI-2) and deactivate DSP with "xrandr --output DSP-1 --off". Then you should see your desired linux desktop.
    Hope it helps!


    Post Reply