HDMI Problem

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 2
    Joined: Mon Oct 12, 2020 11:27 am

    Mon Oct 12, 2020 11:40 am

    Hello everyone,
    I have the 2G/32G LP . When I use the LP with the Waveshare 7.9 inch HDMI touch screen, the screen disappears completely after the tearing. When I run LP with another screens it works fine and
    the Waveshare screen is working properly when I use it with another PC.
    I tested hardware and software for a long time,
    I changed the screen resolution settings, update drivers and gave 5V- 5.7V/ 2A - 3A to the input of the LP but
    I could not find the problem. I wonder the CPU display driver used in this version is supported or not, if I switch LP 2G/32G to Alpha 800 series the problem will disappear?

    Waveshare Screen: https://www.waveshare.com/wiki/7.9inch_HDMI_LCD
    WaveShare Chip : Toshiba 358779XBG

    User avatar
    Site Admin
    Posts: 2690
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Oct 14, 2020 4:33 am

    Have you tried re-plug the HDMI cable?Or restart the board? We've been in a similar case once, but it is becasue the problem of compatibility,so it need plug on the board then power the board.
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 2
    Joined: Mon Oct 12, 2020 11:27 am

    Wed Oct 14, 2020 6:40 am

    Yes, I have tried these cases but it still continues.

    User avatar
    Site Admin
    Posts: 2690
    Joined: Wed Jan 20, 2016 9:09 am

    Fri Oct 16, 2020 6:42 am

    It sounds strange, HDMI should be a standard video interface. Try set display setting only on HDMI screen.
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 1
    Joined: Sun Nov 01, 2020 7:54 pm

    Wed Nov 04, 2020 9:34 am

    Hello, I also have the problem with the 7.9 inch display, but I use the 4G / 64G. does the LP support the resolution of 400x1280p? The LP runs in combination with the display for about 1 minute, then the image flickers and then it is only blue. I think after that the LP is also in a boot loop, the red LED goes on and off again and again and I can only start it again after I have switched the power off and on again.

    Post Reply