Lattepanda Alpha Not booting After First reflash for autopower on

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Ajith P Joseph
    Posts: 1
    Joined: Thu Nov 19, 2020 4:33 am

    Fri Nov 20, 2020 3:22 am

    Hi, I received my LP Alpha and I booted it with Ubuntu 16.04LTS. I needed my OS to boot when power is on. So went for the method that is given in the link below to Reflash my BIOS (LattePanda Alpha Updated BIOS for Auto power-on --Beta Version).


    I am having Alpha m3-7y30.

    The first reflash went good and after that I used "Ctrl+Alt+Delt" to restart the system to go to second reflash. But at this moment that screen went of no display. I tried other HDMI cables but no screen.

    Then I tried Hard reset but was no good.

    I removed RTC battery and booted but It was not getting booted.

    I need a solution for this problem.

    Can I restore the BIOS using a programer??

    Post Reply