LATTEPANDA not booting after BIOS Update

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    janez4519
    Posts: 1
    Joined: Sun Jul 03, 2016 6:20 pm

    Sun Jul 03, 2016 6:30 pm

    Hi,

    I tried to update may LATTEPANDA 2/32 to the auto start BIOS, after successful flashing it the Lattepanda won't boot at all (there is no picture on the screen, the red LED is ON)

    Does someone have a solution on that (How can I force a BIOS re-flash it).

    User avatar
    bruce_campbell
    Posts: 3
    Joined: Mon Jul 18, 2016 7:42 pm

    Mon Jul 18, 2016 8:09 pm

    Hi, guys!

    Got the same issue for me. The blue LED flashing, the red LED still lights bright and no boot :cry:
    Any chance to reset bios, like on PC manner? I mean set jumpers or remove the battery or so on.

    Regards,
    bc

    User avatar
    LattePanda
    Site Admin
    Posts: 2690
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Mar 29, 2017 9:38 am

    Thanks for your feedback.
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Micha_ub
    Posts: 1
    Joined: Thu Oct 01, 2020 1:58 pm

    Thu Oct 01, 2020 3:29 pm

    I have the same problem. I have contacted the support of lattepanda. At first they advised me to flash the BIOS directly again, flashing loudly worked too, but the lattepanda still does not start - red LED lights up and blue LED flashes. Proceeded with these instructions: https://www.lattepanda.com/topic-f20t21033.html

    Now I should send the lattepanda to China for repair.
    But that is not so easy with the customs regulations.

    Can someone in Europe solve the problem?
    Thanks a lot!
    Michael

    Post Reply