Page 6 of 10

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Mon Jul 16, 2018 3:14 am
by Kellman616
Cool :shock: ! How you do that! You mean just replace the config file in Kernel with the one in Ubuntu image? And what changes you make... Can you upload your config file? :D I'm interested in playing Linux! 8-)
raidensnake wrote:
Fri Jul 13, 2018 2:12 am
@Lattepanda I found out the kernel you have has a bug in the sd card driver. I was able to custom build kernel 4.17.6 from the kernel.org site and use your config file in the ubuntu image with a few minor changes it was asking for and it worked. Even all of the other hardware works.

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Mon Jul 16, 2018 10:23 am
by LordGG
LattePanda wrote:
Mon Jul 16, 2018 3:00 am
The image and bios released works with 4G model. Just a known issue we are working on. But as I know, you can still install and use it for 24/7 working without any problem. ;)
Thank you ! :)

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Fri Jul 20, 2018 2:40 pm
by raidensnake
Kellman616 wrote:
Mon Jul 16, 2018 3:14 am
Cool :shock: ! How you do that! You mean just replace the config file in Kernel with the one in Ubuntu image? And what changes you make... Can you upload your config file? :D I'm interested in playing Linux! 8-)
This is the config file from the ubuntu image. The only things modified were changing options from m to y that were warnings. The whole config hasn't changed.
lattepanda_defconfig.zip
lattepanda Kernel Config 4.17.6
(47.6 KiB) Downloaded 663 times
For the record all of the hardware does work on both Debian/ubuntu (may work on others)

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Mon Jul 23, 2018 7:55 am
by diego
Hello,

are you planning to release all the information about the changes that you have done in your ubuntu image? (configurations, kernel, ...)

I think it would be good to have a "respin project" for several linux distributions like it is done for the gpd pocket (https://github.com/stockmind/gpd-pocket-ubuntu-respin)

/diego

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Sun Jul 29, 2018 12:06 pm
by raidensnake
I apologise. I need to make some revisions as I discovered 2 main issues that were unexpected.

1. kernels 4.15 to 4.17 and 4.18 (testing) have a known bug with the Intel SST audio chip not outputting sound via the 3.5mm jack. The HDMI LPE does however work. (Broken audio after 4.12)

2. Kernel 4.12 the Intel SST audio chip works but the MicroSD card is not functioning.

Update:

3. on kernel's 4.13 and 4.14 neither the Intel SST audio chip or the microsd card work

I'm testing every kernel revision to find out what caused this and if there's a way to resolve it. Everything else works just as before with no config changes needed.

Update 2: The possible cause is a change to the audio codec code for the rt5645. I'm going to try and patch 4.15 with code from 4.12 to see if it fixes the sound issue. All other functions work.

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Sun Aug 05, 2018 3:35 pm
by doanldshimoda
People, any body is getting ocasional system error windows? Or in terminal Segmentation fault(core dump) messages? Or im alone with this? What im worried is latte panda on linux is VERY unstable or is my impression? I dont care if some device is not supported, that will be supported soon, but what im worried is the inestability in the total system... All the time i get core dumps. Anybody else?

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Sat Aug 25, 2018 4:14 am
by raidensnake
@lattepanda I found out what's going on with the MicroSD card issue in the ubuntu image and kernel 4.12.14. The kernel lacks the support for modern SDXC cards It only supports the older ones like the early Samsung ones up to 64GB for example. Seems like changes to the acpi/pci code and mmc core that took place in kernel 4.15 allow modern SD cards to function like my Sandisk 200GB SDXC Card. If you can it would be good to implement this into the older 4.12 kernel to address the storage issues. The Audio works flawlessly in 4.12.

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Wed Sep 05, 2018 4:40 pm
by clusher
Hello everyone,

I am trying to install Ubuntu in LattePanda, following the documentation. Everything went smoothly, except that the HDMI display loses signal after choosing Ubuntu in GRUB.

- I have checked the LP version is correct: S70CR200 - Z835
- I updated the BIOS using the files in the documentation, and no errors occured.
- I installed the Ubuntu image provided in the documentation, again with no problems.
- I have a Wireless Bluetooth Mouse/Keyboard and a HDMI (to VGA) display.
- When I reboot LP, I get to GRUB and choose "Ubuntu". After that, some letters appear (too fast to read) and sometimes even a cursor appears for 1 sec. After that, the screen goes black and displays "Check Signal Cable".
- I have confirmed MIPI is disabled in the BIOS > Chipset > North Bridge. Afterwards, I even turned off the "Force Lid Status" . Still no luck.
- I have also tried a direct HDMI display, but the red LED never turned off.

Any suggestions on what to do next? I suppose the problem is to get Ubuntu to recognize the HDMI as the primary display...

Thank you,
Carlos

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Tue Sep 11, 2018 12:19 pm
by sreevan
I installed the official Ubuntu image and then successfully upgraded it to 18.04 too with almost all hardware working properly on the latest Lattepanda 4G/64GB version. It took almost a month for me to get to this stage and ran into many problems like Ubuntu not bringing up the desktop, not booting etc etc but got it all solved one by one. Since i had to connect my intel realsense camera to it, i had to upgrade the kernel to 4.15 from the original 4.12. After this, had few other problems to sort out and mostly successful except the sound output on the 3.5 mm jack. I am struggling to resolve it for quite some time but unable to, so thought would turn to experts by posting this. Can someone please help me in solving the sound output problem?

I do hear some strange noise when i scroll up/down on certain windows and when booting up (like whirring of disks) but no audio though. Tried all solutions suggested on the net, pulseaudio reinstall, alsa reinstall, changing default output in asound.conf, changing default.pa to force output to specific sink etc but no luck.

I see that @raidensnake has indicated this to be "not yet solved" problem and also he doing some work still. If any tips you could pass on, it would be greatly appreciated. Thanks.

Re: Beta Ubuntu Image for LattePanda - Official version

Posted: Sat Sep 15, 2018 12:51 am
by raidensnake
sreevan wrote:
Tue Sep 11, 2018 12:19 pm
I installed the official Ubuntu image and then successfully upgraded it to 18.04 too with almost all hardware working properly on the latest Lattepanda 4G/64GB version. It took almost a month for me to get to this stage and ran into many problems like Ubuntu not bringing up the desktop, not booting etc etc but got it all solved one by one. Since i had to connect my intel realsense camera to it, i had to upgrade the kernel to 4.15 from the original 4.12. After this, had few other problems to sort out and mostly successful except the sound output on the 3.5 mm jack. I am struggling to resolve it for quite some time but unable to, so thought would turn to experts by posting this. Can someone please help me in solving the sound output problem?

I do hear some strange noise when i scroll up/down on certain windows and when booting up (like whirring of disks) but no audio though. Tried all solutions suggested on the net, pulseaudio reinstall, alsa reinstall, changing default output in asound.conf, changing default.pa to force output to specific sink etc but no luck.

I see that @raidensnake has indicated this to be "not yet solved" problem and also he doing some work still. If any tips you could pass on, it would be greatly appreciated. Thanks.
Like I said the audio issue affects all kernels 4.13+ on intel atom chipsets that either uses the 3.5mm jack using the rt5645 or the intel HDMI lpe chips. It's still not fixed even on the latest 4.18/4.19 kernels.