[DEFECTIVE] Alpha 864 dead

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
tommytyker
Posts: 2
Joined: Sat Jan 05, 2019 7:50 am

Wed Sep 25, 2019 7:15 am

Hi,

My Alpha 864 died randomly the other day. It was using the supplied power adapter (usb c). I followed the guides here for using the 12V direct connect. That did not work either. (No lights). Tried re-wiring the connection and 2 different 12v/36W power supplies (one of them was not powerful enough)

So I guess the board is dead. I think I am too late for an RMA as mine was an original kickstarter order. Shame. It was a perfect little device for me.

User avatar
NPK
Posts: 1
Joined: Wed Jul 17, 2019 4:57 am
Location: Finland

Fri Sep 27, 2019 8:06 am

Hi,

Did you have any external devices plugged in when the system died?

Friends of mine had theirs die when they unplugged the supplied usb-c power brick while they had multiple usb devices plugged in.

Post Reply