Camera Connection issue via USB3 of Lattepanda alpha

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
rollo
Posts: 2
Joined: Mon Oct 14, 2019 9:21 am

Tue Oct 15, 2019 3:15 pm

I am developing a real-time image processing module using Lattepanda Alpha. But there is a problem with running the camera through the USB3.0 ports.

At the first time, I thought it’s probably a cable problem, so I used new cables based on USB3.0 Vision Standard, but this also fails to grab images most time. However, the cables work well in standard desktops and laptops.

One strange thing is, if the cable is longer than 1 m, the camera works fine, but if it is shorter than 1 m, the problem is occurred.
(Long cables cannot be used in my project because the developing module should be made small.)

We tested several lattepanda alphas and every system shows the same problem.
Have you ever had this problem? How I can overcome this? A similar issue was reported in other FAQ in July, but there seems to be no solution yet.

(Wifi might not be the problem in this case, and I have tested USB hubs but I could not find the suitable one. Please recommend one if you solved the problem with it)

User avatar
ccs_hello
Posts: 440
Joined: Sat Oct 13, 2018 9:16 pm

Sun Oct 27, 2019 3:39 pm

Hard to tell, USB3 is putting stringent requirements on many things. Wants better and fast, then many things need to be taken care of.
(BTW, USB-C is even a nightmare.)

One thing I can think of is the USB3.0 connector's outer shell (the metalic contact.)
Some cables have that shield internally connected to the GROUND leads and some don't.
Some have the other shield linked to the other end of USB3 cable's shield as well and some not.
What's the difference? In USB3 SuperSpeed (5Gbps),, proper signal shielding is very important and naturally quality cable (twisted pair throughout is mandatory.

Also, USB3 S.S.. collides with WiFi 2.4GHz big time, try to disale WiFi altogether to verify.

Another: check your USB3 end point device's power requirement. Try to supply power directly to that device (or thru a hub in the device end), instead of using the USB3 cable to pass the power.

Post Reply