[DISCUSSION] Linux on LattePanda

A place to talk about all the Operating Systems, Software & Hardware
Forum rules

- Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.

- Members should post in a way which is consistent with "normal writing". That is users should not post excessive numbers of emoticons, large, small or coloured text, etc. Similarly users should not SHOUT or use excessive punctuation (e.g. ! and ?) in topic titles or posts.

- Members should use an appropriate, descriptive subject when posting a new topic. Examples of bad subjects include; "Help me!", "I'm stuck!", "I've got an error!", etc. Examples of good subjects include; "Getting an TABLE FULL error upon login", "Cannot restore a backup".

- Members are asked to post in English only so that posts can be well received and properly monitored.

- Spam is not tolerated here under any circumstance. This includes offering hosting services (charged and free), installation services, solicitation etc. Recruiting members for your own projects (moderators, designers, professional MOD work, etc.) is not permitted and is also considered spam. Users posting spam will be warned and their post removed.

- Members should post in a way that is respectful of other users. Flaming or abusing users in any way will not be tolerated and will lead to a warning. Vulgar language and inappropriate material is not allowed and will be removed. We try to maintain a family friendly atmosphere whenever it is possible within the main subject matter of this community. Please keep this in mind when participating.

- Each user is allowed to create one account. If you would like to change your username, please contact us and, most likely, we can do it for you while you can keep all of your profile data, posts, and other content.

- If a user violates our guidelines and shows a disregard for them, our staff and our community, they run the risk of losing their account. We reserve the right to deactivate any account and to edit or remove any content without warning. These guidelines are subject to change at any time without notice.

Thank you for visiting LattePanda.com!
User avatar
Coco Xia
Posts: 75
Joined: Wed Aug 02, 2017 8:36 am

Fri Nov 24, 2017 10:29 am

jasongaunt wrote:
Thu Nov 23, 2017 7:15 pm
Er, Coco Xia, what are you talking about?
  • WiFi works with a BIOS tweak and a settings file, please read this post: https://is.gd/lattepandalinuxwifi (shortened URL but it links right back to these forums)
  • Ethernet works right out the box with Ubuntu 16.04.3 LTS although the interface name is something like enx???????????? (where ? is the mac address)
BT I don't know. It sees hci0 but it won't allow me to bring it up.

Hi, thanks for your reply! Actually i just install the ubuntu 16.04.3 on 4G version, but the WI-FI , Ethernet and Bluetooth all can not use! :cry:
I will try the solution. Thanks again.

User avatar
ndang
Posts: 2
Joined: Wed Nov 29, 2017 6:53 am

Wed Nov 29, 2017 7:07 am

i have installed ubuntu server 16.04
i have problem with my wired network,
* network Disabled
can help me please ....

User avatar
Coco Xia
Posts: 75
Joined: Wed Aug 02, 2017 8:36 am

Wed Nov 29, 2017 8:14 am

ndang wrote:
Wed Nov 29, 2017 7:07 am
i have installed ubuntu server 16.04
i have problem with my wired network,
* network Disabled
can help me please ....
Hi, friend! did the Wi-Fi works well? :)

User avatar
jasongaunt
Posts: 9
Joined: Tue Feb 28, 2017 2:58 pm

Wed Nov 29, 2017 8:26 am

I had no luck with networking on Ubuntu Server - the ethernet driver appears to only be present in Ubuntu Desktop.

What I did was install the desktop version and then disable the GUI. It happily runs SDR and an nginx proxy without any crashes or hangs :)

User avatar
ndang
Posts: 2
Joined: Wed Nov 29, 2017 6:53 am

Wed Nov 29, 2017 10:35 am

Hi, friend! did the Wi-Fi works well? :)
[/quote]

No, the Wi-Fi not detected

UPDATE :

in here : https://www.youtube.com/watch?v=O5_yuCJKHig
running on ubuntu 14.04

for ubuntu 16.04
in /etc/network/interfaces :

auto enx00e04c36xxxx
iface enx00e04c36xxxx inet dhcp

it work

User avatar
Coco Xia
Posts: 75
Joined: Wed Aug 02, 2017 8:36 am

Thu Nov 30, 2017 9:21 am

I can't believe that the Ethernet and WiFi works now. :lol:
Actually Ethernet works right out the box with Ubuntu 16.04.3 LTS , I just did something wrong in the earlier time.
And i use the way below to make the WIFI works. Posted by LattePanda.
http://www.lattepanda.com/topic-f6t58p4 ... wifi#p4807

User avatar
Ternarous
Posts: 17
Joined: Fri Nov 10, 2017 10:58 am

Tue Dec 05, 2017 6:13 pm

palladion wrote:
Mon Nov 06, 2017 8:32 am
Hey,
I recently bought mine (4/64GB version) to play around with it and install Mycroft "AI" on it. As for the Linux support i went with Kubuntu with 4.13 kernel. Installation and booting went without any problems (64bit UEFI + 64 bit system). Wireless also works out of the box for me. Some minor flakiness that seems to have gone away by itself.

What does not work for me out of the box:
* Bluetooth - i have not applied any patches from the official github debian image as i don't care so much about Bluetooth
* Audio - i have applied the fixes however i could not get it to work.

Audio has another issue that is not related to the Lattepanda. Apparently the new pulseaudio version has problems with HDMI audio and constantly crashes -> no audio at all. So i blacklisted it to prevent the kernel modules from loading. Now pulseaudio works for me and I have an active microphone input (at least the signal-meter is jumping around)

I have spent hours on getting the audio jack to work and I don't know what else to do. I patched, reconfigured, reinstalled and changed all the possible settings. I can not get it to work with my headphones.
If anyone has an idea about that I would be very glad.

HDMI Bug Info:
* https://bugs.freedesktop.org/show_bug.cgi?id=100488
* https://bbs.archlinux.org/viewtopic.php?id=135782
Please, give me most detailed, step-by-step description, applicable for newby in linux, how you blacklisted (what?) and repaired HDMI audio. It's very hot issue, I think not only for me.

User avatar
LattePanda
Site Admin
Posts: 2173
Joined: Wed Jan 20, 2016 9:09 am

Thu Dec 07, 2017 2:51 am

Hey guys,
There is someone sharing.The wifi, Bluetooth and Arduino can works well. Just check to get more info. :)
http://www.lattepanda.com/topic-f10t165 ... html#p7426

And thanks @leogx9r.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
ChrisPanda
Posts: 2
Joined: Tue Dec 19, 2017 6:23 pm

Tue Dec 19, 2017 7:35 pm

Hi all, on Page 15 of this thread site Admin LattePanda wrote:
"Note: Installing Ubuntu will wipe Windows from your LattePanda. After wiping it is not straightforward to restore it!!"

I wiped Windows 10 completely off not knowing that it creates such an issue!!!

I can't get Windows 10 reinstalled. I just don't know what to do anymore. Windows 10 doesn't boot from USB anymore. It seems like no chance of getting Windows 10 back reinstalled :( Is there anyone who can help solve this issue?

thanks in Advance guys

User avatar
LattePanda
Site Admin
Posts: 2173
Joined: Wed Jan 20, 2016 9:09 am

Wed Dec 20, 2017 8:58 am

Hi, can this help you? Please try! :)
http://www.lattepanda.com/topic-f10t1316.html
Enjoy Tinkering with LattePanda ! :lol:

Post Reply