Page 24 of 27

Re: [DISCUSSION] Linux on LattePanda

Posted: Mon Jan 08, 2018 6:23 am
by LattePanda
Hi, if you want to send the log file you can contact techsupport@lattepanda.com and please share this topic in the email.
Do you have any idea to fix the problem ? :?:

Re: [DISCUSSION] Linux on LattePanda

Posted: Wed Feb 21, 2018 3:51 pm
by edtguy
Hello,

I am, so far, unable to configure wifi on a LattePanda 2Gb/32Gb.
I have installed Debian GNU/Linux 9 (stretch) 64-bit.
uname -a returns Linux debianpandacat 4.14.0-0.bpo.3-amd64 #1 SMP Debian 4.14.13-1~bpo9+1 (2018-01-14) x86_64 GNU/Linux
I changed the bios setting for SCC SDIO Support to be PCI.
When I run lsmod | grep 8723 it returns the following:

r8723bs 712704 0
cfg80211 716800 1 r8723bs
mmc_core 163840 5 sdhci,sdhci_pci,mmc_block,sdhci_acpi,r8723bs

However, when I click on the network icon on the screen header in gnome, click on the wifi symbol and choose "Select Network", the pop up shows a spinner with "No Networks" underneath it.
I'm not sure what to test or modify next, so any suggestions are most appreciated.

Re: [DISCUSSION] Linux on LattePanda

Posted: Wed Feb 21, 2018 4:55 pm
by edtguy
I figured it out after seeing an error -2 in dmesg for rtl8723bs_nic.bin.
It turns out that this file was missing. I found a copy at https://github.com/hadess/rtl8723bs/blo ... bs_nic.bin, copied it into /lib/firmware/rtlwifi and rebooted.
Wifi is working fine now.

Re: [DISCUSSION] Linux on LattePanda

Posted: Mon Feb 26, 2018 7:09 pm
by edhumble2
Good day Ladies and Gents. :D
After Months of tinkering around with various installations, I finally have one where everything works. WiFi, Bluetooth, Audio and HDMI video all work with no known problems. This installation uses Ubuntu Unity 16.04.0 that has a base kernel of a 4.4.0-112 with the 4.12 Rc-1 Git Hub Patched Kernel as has been suggested in previous postings.

I found several things that could crash the install along the way and everything is detailed in this video:
https://www.youtube.com/watch?v=tFued1mRx2o
Please note that it uses the 4/64 Z8300 Processor version of the Panda, is a 64 bit installation, and works completely with all updates/upgrades after installation.

Enjoy! :lol:

Ed Humble

Re: [DISCUSSION] Linux on LattePanda

Posted: Fri Mar 02, 2018 10:11 am
by LattePanda
Hi, many thanks for all sharing, i will test it later and update here. :)

Re: [DISCUSSION] Linux on LattePanda

Posted: Thu Mar 15, 2018 9:21 pm
by robotist
Hi linux-on-LattePanda-lovers

I have 4/64 Z8300 with strong power supply (5V 30A :D ) and other needed parts. I have been trying not to get crazy with linux, EFÄ°, boot, grub stuffs for days. :? So far I'm at that stage:

- Tried to use dual both with Windows, couldn't succeed. I saw, some use "remove Windows and install Ubuntu" choice, but didn't appeared on mine. Then I removed everything about Windows.
- Advanced options for Ubuntu has 4 different Kernels with 3 options for each: normal, upstart, recovery mode (also have "GNU Grub version 2.02^beta2-36ubuntu3.17" as title at top)
- 4.13.0-37-generic | 4.13.0.36-generic | 4.12.0-rc1-panda | 4.4.0-2017022104 | I somehow installed those famous 2 different Kernels from: https://www.youtube.com/watch?v=tFued1mRx2o and https://goo.gl/ePa3Nd


Those are the results for some of those selections:
- None of the Kernel options boots into ubuntu. Stucks at some point.
- 4.13.0-37-generic and 4.13.0-36-generic have same behaviors: When booting normal mode, after some ubuntu logo animation, ends up with error:
/dev/mmcblk0p2: clean 237476/3530752 files, 2392055/14109184 blocks :!:

- 4.13.0-3*-generic (recovery mode) works fine, comes with a recovery menu. I can enter to the system over here by console. That's how I installed those 4.4 and 4.12 Kernel drivers into system 8-)

- 4.12.0-rc1-panda normal selection goes into black screen with blinking cursor only. Then says:
Gave up waiting for root device. Common problems:
bla bla bla...
ALERT! UUID=9ce...-....-...-...... does not exist. Dropping to a shell!

(I'm not writing full of it because it's a very common error type that you probably know)
For solution, from some websites, I found and tried over using recovery console of 4.13.0-36-generic:
lsblk
sudo mount /dev/mmcblk0p2 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt
sudo update-initramfs -u -k 4.8.0-44-generic
sudo update-grub


It must not be that hard! I couldn't count how many times I installed Ubuntu and used boot-repair tools, efibootmgr, recovery mode, update-initramfs, update-grub, editing grub.cfg file, changing bios settings... :(
I could provide any info you want from the system if I can... Pls Help :|

Re: [DISCUSSION] Linux on LattePanda

Posted: Mon Mar 19, 2018 4:29 pm
by Zoriy
Hi All!

At once I apologize for my English.
I have:
- LattePanda 4G / 64GB Z8350 with power supply 5V 3A
- Debian 9 4.14.0-0.bpo.3-amd64

The last two weeks I've been struggling with the next problem, the following error occurs when playing audio:

Code: Select all

kernel: [210.355526] Audio Port: ASoC: no backend DAIs enabled for Audio Port
Drivers on the sound card are present

Code: Select all

cat / proc / asound / modules
 0 snd_soc_sst_cht_bsw_rt5645
 1 snd_hdmi_lpe_audio
BUT, under no circumstances can I achieve a sound output, also I could not find a clear description of this error.

Who faced this situation?


Ps: I tried Ubuntu 16.04 kernel https://github.com/mopplayer/lattepanda-mainline-4.11
the problem was the same.

Re: [DISCUSSION] Linux on LattePanda

Posted: Thu Mar 22, 2018 3:15 pm
by Zoriy
in the continuation of the conversation ...

After installing and applying the patch, wi-fi bluetooth audo worked, but I ran into another problem: when capturing sound through a microphone, I get a file containing only white noise.
Has anyone encountered this problem?

Re: [DISCUSSION] Linux on LattePanda

Posted: Fri Mar 23, 2018 5:07 am
by LattePanda
Hi all, we are working on the official Linux now, maybe will have the good news soon.
Thanks for all focus.
Let's waiting for it ! ;)

Re: [DISCUSSION] Linux on LattePanda

Posted: Mon Mar 26, 2018 9:27 am
by Zoriy
This is great new!!
Whether prompt there are approximately terms of release of assembly? Current or next month?