Lattepanda black screen on restore

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 1
    Joined: Sun Oct 18, 2020 4:14 pm

    Sun Oct 18, 2020 5:16 pm

    Hi there!

    I have 2x lattepanda boards 2G/32G CR200 Z8350 and both are presenting the same strange behaviour.

    They both had corrupted windows installation and were not booting.
    I then tried to restore windows installation using the image provided by lattepanda troubleshooting website.
    It boots just fine and patches the image to the memory of the board, prompting to type "exit" at the end.

    After typing "exit" the board reboots and the Windows logo apears with the message "getting devices ready" and at about 30% the screen goes black, "no signal" message on the LCD and no other action is taken by the lattepanda board until it is powered off an back on again.

    Some other times, at about 40% on the same screen as above, it just crashes, reboots and then displays a message stating the computer was powered off unexpectedly and makes me install the image all over again.

    At first I thought it would be an overheating related problem but I'm cooling the board with a huge fan to keep it cool the whole process and the results are the same.

    Any hints on what this might be?

    Note: the USB stick used to this restore process, was also used to restore other lattepanda boards (I have 10+ boards) successfully so I discard the possibility of a corrupted usb stick.

    thank you for your help

    User avatar
    Site Admin
    Posts: 2720
    Joined: Wed Jan 20, 2016 9:09 am

    Mon Oct 19, 2020 8:20 am

    Hi, can you share the screenshot of the error image? and what power adapter did you use? could it shutdown due to insufficient power supply?
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply