Arduino under Ubuntu

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 1
    Joined: Fri Jul 19, 2019 10:24 am

    Fri Jul 19, 2019 1:59 pm

    I wonder if anyone has had any success in getting Arduino IDE to work under Ubuntu.

    I've just obtained a LattePanda 2GB/32GB which I've upgraded to Ubuntu 16.04 using the binary on the LP website. All seemed to be working until I tried to install the Arduino IDE.

    I understand that the IDE in the Ubuntu repository is not up to date so I downloaded and installed Arduino IDE 1.8.9 from the Arduino website. I have previously used this under Ubuntu on a PC but it will not work on the LattePanda. The IDE starts initially, and then displays at the bottom Initializing Packages... and then Preparing Boards... and then Starting... However, after a few seconds, the Arduino window disappears and the IDE is not displayed.

    Any pointers would be very much appreciated.

    User avatar
    Posts: 4
    Joined: Sun Sep 01, 2019 8:29 pm

    Wed Sep 04, 2019 9:19 pm

    I successfully got the Arduino 1.8.9 IDE running on Ubuntu. However I've had many issues since then in actually uploading even the example sketches such as blink.
    You could try the Arduino cc online version, which also 'worked' for me.
    I would be very interested to hear if you can reliably upload sketches if you try the online IDE.
    Good luck

    Post Reply