[RESOLVED] How to blind recover from no HDMI output after bios edit

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    User avatar
    Posts: 146
    Joined: Wed Dec 27, 2017 3:55 pm

    Fri May 10, 2019 7:05 am

    LattePanda 4/64 Z8300 Cpu
    But that did not solve my problem.
    The LattePanda still boots into Windows and I am flying blind 'til the Windows boot logo.

    I'm having trouble, I'm getting an image through a 7 "LCD
    I can't get an image from HDMI,
    7 "LCD I removed the image on HDMI does not come unfortunately.
    HDMI cable unplug / plug with HDMI working

    User avatar
    Posts: 37
    Joined: Sat Nov 17, 2018 2:23 am

    Sat May 02, 2020 4:46 am

    So interesting find. I wasn't able to get hdmi output no matter what I did. But when I plugged it into a higher resolution then 1920x1080. And was able to see the boot and bios screen.

    Hope this helps out.

    User avatar
    Posts: 3
    Joined: Tue Nov 10, 2020 10:04 am

    Thu Nov 12, 2020 8:10 pm

    Xboxclassic wrote:
    Mon Mar 27, 2017 12:43 pm

    In addition to XBoxClassic's great advice. - Here comes the same trick for a similar problem:

    In case you switched your lattepanda to "use build-in-display [that's display 1] only"
    the HDMI-Output will disappear on booting windows. - LP just shows a black screeen.
    Here's the solution :
    Switch your LattePanda on and give it time to startup Windows completely.
    Continue as follows. You won’t see what you do, but it works, though:
    - Type your password
    - Press Enter
    - Press the Windows-Key plus he letter P
    - Press the arrow-down-key once
    - Hit Enter
    And (by magic ;-) the window screen will appear again on your HDMI display.


    User avatar
    Posts: 3
    Joined: Wed Nov 21, 2018 5:08 pm

    Thu Apr 08, 2021 10:10 am

    I'm also having this issue.

    No output at all untill it boots into an OS...
    The bios reset trick at the beginning of this thread did nothing :(

    Have found a workaround in that i get video out if i plug in the Anker USB-C dock i got for my laptop: The HDMI output on that works fine :)

    Though it would be nice to fix this, any ideas?

    User avatar
    Posts: 1
    Joined: Wed Apr 14, 2021 8:15 pm

    Thu Apr 15, 2021 6:32 pm

    I'm having the same issue right now. I flashed the bios for autoboot and since the first flashing it hasn't been able to display any video.

    User avatar
    Site Admin
    Posts: 2760
    Joined: Wed Jan 20, 2016 9:09 am

    Fri Apr 16, 2021 3:57 am

    nightside180 wrote:
    Thu Apr 15, 2021 6:32 pm
    I'm having the same issue right now. I flashed the bios for autoboot and since the first flashing it hasn't been able to display any video.
    Your issue is different from that in this post. We suspect you have updated a wrong BIOS for your LattePanda. Pls contact techsupport@lattePanda.com for help.
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply