[RESOLVED] Installing Windows when USB boot fails

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    User avatar
    Posts: 1
    Joined: Fri Jun 16, 2017 5:41 pm

    Mon Jun 19, 2017 10:23 pm

    Here I document my trial-and-error methods for booting the Windows OS install when the BIOS boot order was getting ignored. Another alternative title might be How I managed to install Windows when I could not boot from any USB devices. (Tested USB DVD, USB Flash Drives).

    This was a new device, freshly unpacked and booted up. I experienced issues starting Windows for the first time. "OS goes to "Just a moment" for a very long time. Then the sysprep cmd window launches, then nothing happens." This issue is identical to this reddit post and has been posted a few times on the LattePanda forum already.

    I followed the LattePanda documentation on reinstalling Windows to create the bootable USB stick. I set the boot order in BIOS, but it still just kicked me back to the pre-installed windows.

    So I tried a different USB stick (sometimes they can be fussy) but the results were the same.
    It just refused to boot to USB! Always defaulting back to the pre-installed Windows.

    Next I grabbed a windows 10 home DVD and plugged in my trusty USB 2.0 DVD burner. It has it's own power source, so I was sure there wouldn't be any power draw issues. I accessed the BIOS and set my boot order. To my dismay, the system still refused to boot to USB (Just loaded the pre-installed Windows again.)

    Next I used Microsoft's media creation tool and created a Windows 10 32-bit bootable USB stick. (32-bit because I am working on the 2G/32G version of the LattePanda, I shouldn't need the 64-bit version... or so I thought. read on!)
    While it was downloading I did other stuff to shake my frustrations. Once finished, I connected the newly imaged USB stick to a different, working PC. It booted to the windows setup as expected.

    I plug the USB stick into the 'Panda, change bios boot order settings... and it goes right back to the pre-installed windows. Won't boot from the USB stick or the USB DVD.

    Ok, so that won't work. I get into the Windows troubleshooting start menu and I select the option to restore my PC, don't keep any settings. I start this process.

    Around 49%, I get hit with a brief power outage. Hmm... at least it wasn't firmware, right? I wait for a bit to make sure the power is stable again, then I start it up. That's when I am greeted by a not-so-nice message:
    "The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click 'OK' to restart the computer, and then restart the installation.".


    I got this same mesage no matter how many times I tried to F8 or otherwise access any windows safe mode.

    Great. So now my pre-installed image is shot and I can't get this thing to boot from any USB device.
    I really didn't feel up to installing and configuring a PXE server just for a single Windows 10 install. So I kept on tinkering.. and while tinkering, I noticed an entry on the BIOS exit screen labeled "Launch EFI Shell from filesystem device".


    I ran this and after a moment I was provided a command line to the EFI shell. Cool. Reading the screen I notice the mount points and read to figure out which is my USB device. In this case, fs1:


    I mounted my USB device by typing fs1:
    then I typed cd efi
    then I typed cd boot
    then I typed in bootia32.efi
    I was immediately notified that the Image type IA32 is not supported by this x64 shell. so, Microsoft used the Itanium efi on the x86 version of Windows 10 home? That just doesn't make sense.


    So, once again I used Microsoft's media creation tool and created a Windows 10 64-bit bootable USB stick.

    Once the stick was ready, I launched EFI Shell from the BIOS. Ran these commands (again):

    cd efi
    cd boot


    Success! The shell launched the Windows setup program from the USB device.
    Because of the problems I was having, I decided to delete the hard disk partitions and reinstall windows on a clean 'unallocated space' emmc disk.


    Afterwards, on another computer I downloaded the drivers from the LattePanda GITHub repository and transferred via the same USB stick. Then I proceeded to install drivers for all the unknown devices in the device manager. (it was a pretty long list.)

    I had neglected to remove the USB stick from the LattePanda when I rebooted to finish installing the first of the device drivers. To my surprise, the 'Panda booted from the USB stick. So after the clean OS install my LattePanda began properly booting from the USB devices.

    I removed the USB stick, rebooted into Windows and continued with device driver installation. I've since then updated Windows and have let the device 'burn in' for a day. It seems to be working perfectly now.

    I hope you find this post informative and helpful. Use these instructions at your own discretion.

    User avatar
    Site Admin
    Posts: 2661
    Joined: Wed Jan 20, 2016 9:09 am

    Mon Jun 26, 2017 3:01 am

    VERY clear and detail tutorial. Really appreciate your effort and we will share your tutorial to people who meet with the same problem! :)
    Will be really helpful!
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 1
    Joined: Wed Jun 28, 2017 4:49 am

    Fri Jun 30, 2017 2:25 pm

    Thank you the instructions were perfect and I have managed to reinstall the image. The other points I have found:
    1. Getting to BIOS was an issue sometimes the ESC key works sometimes not – might be my keyboard I guess.
    2. Power is certainly an issue, we ended up running it off a bench power supply to ensure sufficient power. I suspect 2A is borderline.

    User avatar
    Coco Xia
    Posts: 75
    Joined: Wed Aug 02, 2017 8:36 am

    Fri Aug 04, 2017 10:06 am

    Hi , thanks a billon. The tutorial is clearly enough , I have solved my problem by following it. Best wishes. :D :D

    User avatar
    Posts: 2
    Joined: Sun Nov 19, 2017 6:22 am

    Sun Nov 19, 2017 7:15 am

    1.use una USB 3.0 de 16GB
    2.darle formato en otro latte 16kilobytes y "WINPE" como etiqueta
    3.extraer con 7.zip luego de abrir comprimido
    El directorio DF-JX-7-S70CR110_CC55D-001-E
    De 5.85GB 206 archivos
    4.no cambiarle nada.
    5.colocarla en USB 3
    5. Conectar un switching poder supply RS 15-5 Mean Well (MW) 3amp
    6.cuando apague el led rojo usar botón encendido
    7.cuando solicite un Exit quite la fuente.
    8.disfrute su LattePanda

    User avatar
    Site Admin
    Posts: 2661
    Joined: Wed Jan 20, 2016 9:09 am

    Mon Nov 20, 2017 3:15 am

    Thanks for your feedback!
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Renato Rocha
    Posts: 2
    Joined: Thu Apr 12, 2018 4:06 pm

    Thu Apr 12, 2018 4:18 pm

    Thank you very much QuakeDragon!!
    I was having similar problems after installing debian on my LattePanda (32Gb/2Gb).
    The bios wouldn't boot from the usb even when I changed the boot priorities.
    After running the Microsoft Media Creation tool on a usb stick I plugged it in the LP and it automatically booted properlly ready to re-install Windows.
    I was struggling with this issue for 2 days until I found this post!
    I'm kind of a newbie to these informatic problems but I was wondering, since your LP now boots properlly through an USB stick couldn't you just install
    the LP Windows 10 version instead of installing all the drivers and extra packages one by one?
    I don't really know if this solution really solves the Bios booting problem but will check it out soon.

    Congrats on the post

    User avatar
    Site Admin
    Posts: 2661
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Apr 17, 2018 8:21 am

    Hi Renato Rocha ,welcome to the forum. How's everything going? :)
    Did you solve your problem?
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 1
    Joined: Wed Jun 20, 2018 12:11 pm

    Thu Jun 21, 2018 7:24 am

    Thank you !!!!!!!!!!!!
    Best article - respect!!!!!!!!!!!!!!!!!!!!!!

    User avatar
    Posts: 7
    Joined: Sun Jul 22, 2018 8:47 pm

    Fri Aug 03, 2018 4:21 pm

    I believe latte panda staff must resolve that problems. How is posible cannot install windows 10 on latte panda? I foloow the procedures ans UDB never boot. I get my board yesterday from lattepanda suplly. Is a shame. Seems like hacking stuff dont have sense to hack and you expect to work out of the box like araspberry pi or any other IOT board. Im very dissapointed.

    Post Reply