Missing parts of orders

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    irishbiker
    Posts: 6
    Joined: Sat Apr 16, 2016 10:44 am

    Sat Apr 16, 2016 10:49 am

    Hi

    I ordered a screen and a capacitive touch panel overlay but I've only received the board. when will the remaining parts be shipped?

    User avatar
    DrWho
    Posts: 1
    Joined: Sat Apr 16, 2016 12:02 am

    Tue Apr 19, 2016 11:25 am

    Same problem here! E-mail via kickstarter querying this is so far unanswered. The spreadsheet doesn't help since it does not show additional items other than the case choice. For me the lack of display delivery is not an immediate problem, however whilst my order is clear on the DFRobot site, the connection to LP is not. I would appreciate some acknowledgement that all is well with the order even if delivery date remains uncertain.
    Looking at the comments on kickstarter we are not alone in this.
    On the positive side I'm well pleased with the LP so far - booted first time without issues and has been running solidly for some 60 hours. :D

    User avatar
    LattePanda
    Site Admin
    Posts: 2707
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Apr 19, 2016 4:02 pm

    @irishbiker/DrWho,

    Sorry for the trouble. The thing is we've reported this issue to DFRobot store team. And they promise they will ship the rest of parts for our backers once all these components are ready. If possible, you could directly send an email to store@dfrobot.com to follow up the process.

    Honestly it's a big challenge for a small team to deliver so many packages and get ready everything for the freight forwarder in a short time. We made a mistake in combining the order...Hope you could understand... =-=!
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply