Navigation help please...

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 2
    Joined: Fri Aug 04, 2017 2:46 pm

    Fri Aug 25, 2017 1:23 am


    My antenna's connector is deformed and won't connect, how do i get a replacement, and can i use an external wifi client device on the ethernet port instead, until my replacement gets here...???

    I'd look it up myself but it will take days to decode it with my dyslexia, so keep it short...

    Thanks for your help...


    User avatar
    Site Admin
    Posts: 2657
    Joined: Wed Jan 20, 2016 9:09 am

    Fri Sep 01, 2017 7:21 am

    Sorry for the delay. :(

    LP use a standard U.RL connector 2.4G antenna. So you can use the old antenna from any other device , or buy another antenna from DFRobot, ebay or any local electronics suppliers!

    There is an enhanced 2.4G antenna:
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Site Admin
    Posts: 2657
    Joined: Wed Jan 20, 2016 9:09 am

    Sat Sep 02, 2017 10:09 am

    And the thing is some users also replace the antenna with their old computer components. Any u.RL connector 2.4Ghz antenna should work with LattePanda. You can consider to get them from your other old device or local eletronics shop.

    Feel free to let me know if you still look for a replacement. And post a photo for your broken part. ;)
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 6
    Joined: Thu Jan 10, 2019 12:00 am

    Thu Jan 10, 2019 2:53 am

    I just recieve my alpha and one of the antennas arrived will not attach to the board.

    Post Reply