Installing 64 bit UEFI firmware on 2gb/32gb Lattepanda

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    frederikt
    Posts: 10
    Joined: Tue Sep 19, 2017 1:31 pm

    Mon Oct 09, 2017 7:52 am

    I have a 2gb/32gb lattepanda with 32 bit UEFI firmware. How can I install a 64 bit version on it so it can support 64 bit OS'?

    User avatar
    LattePanda
    Site Admin
    Posts: 2569
    Joined: Wed Jan 20, 2016 9:09 am

    Mon Oct 09, 2017 9:43 am

    Hi, you can try to re-write the BIOS form 32bit to 64bit, you can try it follow the link below and download the BIOS documents, but it may cause some problem. Actually it is suitable for the LP V1.2, i am not sure is it suitable for v1.0 and v1.1, and I will test it tomorrow. :)

    https://github.com/LattePandaTeam/Latte ... bit%20BIOS
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    frederikt
    Posts: 10
    Joined: Tue Sep 19, 2017 1:31 pm

    Mon Oct 09, 2017 11:37 am

    LattePanda wrote:
    Mon Oct 09, 2017 9:43 am
    Hi, you can try to re-write the BIOS form 32bit to 64bit, you can try it follow the link below and download the BIOS documents, but it may cause some problem. Actually it is suitable for the LP V1.2, i am not sure is it suitable for v1.0 and v1.1, and I will test it tomorrow. :)

    https://github.com/LattePandaTeam/Latte ... bit%20BIOS
    Thank you for your reply. I am sorry that I forgot to include some more information that was more specific; I have three Lattepanda boards, one CR110 Z8300 2gb/32gb and two CR110 Z8350 2gb/32gb, none have 64bit UEFI firmware. Since the CPU supports 64 bit, I have considered loading firmware from a different board to hopefully get 64 bit support but I am afraid of bricking my board. That is why I am asking for some advice/help, as it would be greatly appreciated because it's really important for the device I am currently building where I work.

    User avatar
    frederikt
    Posts: 10
    Joined: Tue Sep 19, 2017 1:31 pm

    Wed Oct 11, 2017 7:04 am

    LattePanda wrote:
    Mon Oct 09, 2017 9:43 am
    Hi, you can try to re-write the BIOS form 32bit to 64bit, you can try it follow the link below and download the BIOS documents, but it may cause some problem. Actually it is suitable for the LP V1.2, i am not sure is it suitable for v1.0 and v1.1, and I will test it tomorrow. :)

    https://github.com/LattePandaTeam/Latte ... bit%20BIOS
    Have you tested the bios? It would be greatly appreciated.

    User avatar
    LattePanda
    Site Admin
    Posts: 2569
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Oct 11, 2017 9:53 am

    frederikt wrote:
    Wed Oct 11, 2017 7:04 am
    LattePanda wrote:
    Mon Oct 09, 2017 9:43 am
    Hi, you can try to re-write the BIOS form 32bit to 64bit, you can try it follow the link below and download the BIOS documents, but it may cause some problem. Actually it is suitable for the LP V1.2, i am not sure is it suitable for v1.0 and v1.1, and I will test it tomorrow. :)

    https://github.com/LattePandaTeam/Latte ... bit%20BIOS
    Have you tested the bios? It would be greatly appreciated.
    Hi, I have test it , but maybe the v1.0 and v1.1 can not install the 64bit. After I re-write the Bios, the LP seems can not boot, and I have to re-write to the right version by a programmer to make the LP works normally. Sorry for your inconvenience! :(
    And why do you want to use the 64bit system, is 32bit system not suitable for you? :?:
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    frederikt
    Posts: 10
    Joined: Tue Sep 19, 2017 1:31 pm

    Wed Oct 11, 2017 12:57 pm

    LattePanda wrote:
    Wed Oct 11, 2017 9:53 am
    frederikt wrote:
    Wed Oct 11, 2017 7:04 am
    LattePanda wrote:
    Mon Oct 09, 2017 9:43 am
    Hi, you can try to re-write the BIOS form 32bit to 64bit, you can try it follow the link below and download the BIOS documents, but it may cause some problem. Actually it is suitable for the LP V1.2, i am not sure is it suitable for v1.0 and v1.1, and I will test it tomorrow. :)

    https://github.com/LattePandaTeam/Latte ... bit%20BIOS
    Have you tested the bios? It would be greatly appreciated.
    Hi, I have test it , but maybe the v1.0 and v1.1 can not install the 64bit. After I re-write the Bios, the LP seems can not boot, and I have to re-write to the right version by a programmer to make the LP works normally. Sorry for your inconvenience! :(
    And why do you want to use the 64bit system, is 32bit system not suitable for you? :?:
    Thank you very much for trying. The reason I need a 64 bit OS is because we are making a device that is controlled by a Lattepanda, and the company who are buying the device demands the OS to be 64 bit due to their internal security guidelines. We will try and buy a new Lattepanda instead since the firmware can not be changed to 64 bit.

    User avatar
    LattePanda
    Site Admin
    Posts: 2569
    Joined: Wed Jan 20, 2016 9:09 am

    Thu Oct 12, 2017 1:56 am

    Hi, thanks for your reply and hope every could be fine. Have a nice day! :)
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    ender
    Posts: 124
    Joined: Wed Dec 27, 2017 3:55 pm

    Fri Jan 24, 2020 11:38 am

    How to install CR110 Z8350 2gb / 32 64bit Win10?
    .

    .

    Post Reply