How to Disable Internal Display from BIOS?

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    xieyi
    Posts: 1
    Joined: Sat Dec 09, 2017 11:43 am

    Sat Dec 09, 2017 11:55 am

    Although it is possible to set HDMI display as primary display from BIOS, the non-exist internal display causes a lot of trouble. Specifically, Ubuntu 17.10 sets internal display as primary display and it is not easy to switch to HDMI display without seeing the desktop content. Also, other Linux distributions like to automatically connect to internal display on boot. Since I don't have a display to connect to the board, how to permanently disable it from BIOS?
    I'm using 4G version of Lattepanda.

    User avatar
    LattePanda
    Site Admin
    Posts: 2642
    Joined: Wed Jan 20, 2016 9:09 am

    Mon Dec 11, 2017 7:36 am

    Hi, just try it.

    BIOS->"Chipset"->"North Bridge"->"IGD - LCD Control"->"Force Lid Status"->"Off" .

    Hope it is helpful! Anything new please update here. :)
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    mahdi.khazaee
    Posts: 2
    Joined: Thu Oct 04, 2018 4:15 pm

    Thu Oct 04, 2018 4:22 pm

    Hello to all!
    I accidentally saw above query and answer when I was surfing the web
    then i decided to do this amazing thing...
    it worked! Screen went full black,,,but unfortunately I don't know how to enable it again????
    When I turn on my tablet, there is nothing on screen so that I can turn on the "Force Lid Status"
    please help me
    I am afraid my tablet is dead! ! help me friends....

    User avatar
    mahdi.khazaee
    Posts: 2
    Joined: Thu Oct 04, 2018 4:15 pm

    Fri Oct 05, 2018 3:53 pm

    urgent help needed please

    User avatar
    LattePanda
    Site Admin
    Posts: 2642
    Joined: Wed Jan 20, 2016 9:09 am

    Wed Oct 10, 2018 11:38 am

    @mahdi.khazaee, I think if you connect the HDMI display, you will be able to access the BIOS again and recovery the default setting.
    Look forward to your update!
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    jaypro
    Posts: 3
    Joined: Sat Jan 26, 2019 5:38 pm

    Sat Jan 26, 2019 5:47 pm

    I'm trying to get opensuse running on my latte panda 4g/64. I've updated the bios, installed opensuse, but when it boots, I am brought to a blank screen with only the use of a mouse pointer. The internal display seems to be the active desktop, but I only have a monitor hooked up through hdmi. I thought I would be able to disabled the internal display through the bios, by:

    BIOS->"Chipset"->"North Bridge"->"IGD - LCD Control"->"Force Lid Status"->"Off" .

    ... as mentioned above, but with no luck. I have also tried to toggle:

    BIOS->"Chipset"=>"North Bridge"->"Intel IGD Configuration"->"Primary Display".

    Are there any other options that I can try?

    User avatar
    k3dAR
    Posts: 14
    Joined: Tue Jan 07, 2020 5:14 pm

    Mon Jan 13, 2020 7:49 pm

    disabling in BIOS not work for me, only sollution i found, with GNU/Linux use, is add kernel parameter: video=DSI-1:d
    Xubuntu 18.04 64bit @ LattePanda 2GB/4GB S70CR200-CC34E

    Post Reply