Issues with 7" IPS-Display

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 4
    Joined: Wed Feb 06, 2019 2:10 pm

    Wed Feb 06, 2019 3:36 pm

    Hi Everyone!

    I've a LP Z8300 4/64 since one of the first delivery batches for the Kickstarter backers. Everything seems fine with the board it self. Just the little red power-LED did never work. But this never bothered me. After this long time and a lot of testing, I got an idea for a project as a car-PC. So I've resently ordered the 7" ISP-Display because it fits absolutely perfect.

    Now to the issue. It is similar to the following topics, but sadly there are no solutions:

    When I connect the display while the board is not powered, I'll get those white stripes which will get more or less when something moves around on the screen - I use a HDMI monitor as a mirror screen. I have no problem with powering. Even under heavy load everything else seems fine.

    As soon as I loosen the IPS-connector just enough that the display is not longer powered and fasten it again (no adjustment to the cable is done), the display works fine as long as I don't shut down or restart the board.

    If I shut down/reboot the board, I'll get some ghosting effects of the last screen shown, right before the shutdown/reboot.

    If I shortly disconnect the power supply before the next start up, I'll get the white stripes again.

    Might this be a problem with my LP? If so, is there a possibility for a RMA after this long time?
    If theres no RMA, is there something I need do to get this working?
    And if theres not really something I can do, does someone know a workaround with a connection reset via soft- or hardware?

    If you need more informations, just ask.
    I'll try to provide some pictures as soon as possible.

    Thank you and greetings,

    User avatar
    Posts: 630
    Joined: Sat Oct 13, 2018 9:16 pm

    Wed Feb 06, 2019 4:42 pm

    Yours is LP Classic (ver 1) using MIPI-DSI interface. It should have been posted in a different subforum.
    BTW, the symptom you described seems to be related to lack of power-on reset to the LCD.
    I don't know how LP classic's internal design (don't have that board at all). However, take a look at LRSTB signal and check if it can be asserted after power is applied to get the LCD controller a fresh/clean start.

    User avatar
    Posts: 4
    Joined: Wed Feb 06, 2019 2:10 pm

    Tue Feb 12, 2019 2:10 pm

    Oh, I didn't see the other subforum. Sorry about that and thanks for moving!

    Currently my project is on hold. I was just about to make some pictures and take a look for the LRSTB options when my board suddenly won't boot anymore.
    The blue LED blinks some times, then stops - just like normal. As mentioned before, I don't have the red LED so I cannot tell what this one would do. The board just gets really hot - No output on the MIPI-DSI and HDMI. Seems like some trouble with the BIOS, so I'll reflash it asap and come here back after.

    User avatar
    Posts: 630
    Joined: Sat Oct 13, 2018 9:16 pm

    Tue Feb 12, 2019 3:17 pm

    re: The board just gets really hot

    unplug immediately!
    Check wiring, disconnect unnecessary parts/cables.

    User avatar
    Posts: 4
    Joined: Wed Feb 06, 2019 2:10 pm

    Tue Feb 12, 2019 7:24 pm

    It's note like a "short circuit heating", more like 100% CPU-Usage. Also it won't get hotter than it would while installing Windows.
    But it's allready unplugged and I didn't turn it on since I tried a "hard BIOS reset". Nothing unnecessary is connected - only HDMI.

    User avatar
    Posts: 4
    Joined: Wed Feb 06, 2019 2:10 pm

    Fri Feb 15, 2019 7:59 pm

    Short Update:
    I took a look underneath the "heat spreader". The chip wich get's so hot is the "AXP288C" wich is - according to my research - an essential part for the energy regulation.
    If this is a sign of an defective chip and is not resolvable through a BIOS reflash, my board died - correct me if I'm wrong. Currently a new one would be too expensive so I cannot realise my project :'/

    Anyway, thanks for your help - I really appreciate this! :)

    User avatar
    Posts: 630
    Joined: Sat Oct 13, 2018 9:16 pm

    Fri Feb 15, 2019 11:00 pm

    Sorry to hear that.
    Indeed AXP288C is the main power mgmt IC supplying power to Intel CPU/APU.
    If it gets very hot, quite likely there is a short circuit condition which may exist anywhere in the motherboard and/or inside the CPU IC itself.
    At this point I can only suggest using an eye loupe/magnifier to check if you can find some solder joint melting, an IC gets hot, or a connector's contact pins touching each other.

    Oh, in another thread, a forum user reported that he wipe the old/existing heatsink grease off, reapply the new one, remount the CPU heatsink and the panda automagically working.

    Post Reply