Black Screens

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 2
    Joined: Wed Apr 03, 2019 3:47 pm

    Wed Apr 03, 2019 4:09 pm

    Hello everyone! I have a problem that made me turn from a passive reader to registered member here.

    I have a 4GB RAM/64GB eMMC LP Version S70CR110/S70CR100 Z8300 -> V1.0

    It used to work fine with Windows 10 and the 7 inch IPS Panel connected via the flatflex ribbon cable and a 3A PSU. I then tried to update the bios to the auto-boot version and experienced this:
    1. I followed the steps to prepare the thumbdrive following the description.
    2. I did not connect another display via HDMI.
    3. On start I did not see the Bios update screen, that I expected. In fact the display remained totally black.
    4. After a while I turned off the power and tried to reboot with the thumbdrive disconnected and the display still remained black.
    5. I conected another display via HDMI and didn't get a picture either.
    6. I checked the external display and HDMI cable wit another device -> both work fine
    7. I tried to do serveral hard resets following the description without success.
    8. I tried to follow this instruction for a blind recovery with no hdmi output without success. No picture and the keyboard doesn't even blink.
    9. Trying to flash the default bios blindly din't work either.
    Symptoms wenn connecting to PSU
    • blue led blinks a few times and turns off
    • red led turns on and stays on.
    The only thing I haven't tried is flashing the Bios chip with a programmer. Because I don't have one. Any ideas to solve this issue? :?: :cry:

    User avatar
    Posts: 630
    Joined: Sat Oct 13, 2018 9:16 pm

    Wed Apr 03, 2019 7:38 pm

    I am guessing it's a corrupt BIOS image due to incomplete BIOS flashing process (and by not using the regular HDMI monitor...)
    I think reflash the BIOS chip is the way out. Again, just guessing.

    User avatar
    Posts: 2
    Joined: Wed Apr 03, 2019 3:47 pm

    Mon May 13, 2019 2:27 pm


    I purchased a flash Chip - the GD25LQ64 for my board - flashed it with the default bios for the Z8300 v1.0 revision and verified it, soldered it on the board and still have the blinkingred led.


    User avatar
    Posts: 1
    Joined: Mon May 27, 2019 10:40 am

    Sat Jun 01, 2019 4:29 pm

    I have the same problem. I can not flash LP 4gb /64gb cr200 z8350 c55f. I used the ch341a programmer. Chip on my LP w25Q64FWSIG

    Post Reply