Page 1 of 1

Disabling MIPI display from BIOS not working

Posted: Tue Aug 06, 2019 12:01 pm
by sparkyb
I am trying to use Ubuntu on my LattePanda with only an HDMI display. I want to disable the MIPI display from the BIOS because it causes problems being the primary display when I cannot see it, in text mode, on the login screen, and other places. This is similar to the How to Disable Internal Display from BIOS thread, but I'm reposting this question because I tried the advice in that thread and it did not work for me. I tried setting "Force Lid Status" to "Off" but it had no effect. I also tried other settings but couldn't find any to disable the MIPI display or to even make the HDMI the primary. Per the instructions for installing Ubuntu on the LattePanda, I installed the 1.2 BIOS for Ubuntu. This is with the 4GB / 64 GB eMMC board. Any advice?

Re: Disabling MIPI display from BIOS not working

Posted: Mon Jan 13, 2020 8:05 pm
by k3dAR
with Xubuntu 18.04 i add kernel parameter: video=DSI-1:d

now is finaly present only HDMI display, xrandr show:

Code: Select all

Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
DSI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200     59.95*+
   1920x1080     60.00  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     60.02  
   1280x960      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
   720x400       70.08