Another UART issue ! SOLVED !

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 2
    Joined: Fri May 15, 2020 4:09 pm

    Fri May 15, 2020 6:52 pm

    Hi everyone,

    After reading and trying most of solutions available here and elsewhere, I'm stuck with serial communication. The board LattePanda 2/32 (Activated Win10 with all updates, latest .NET, latest Arduino IDE) is behaving quite strange with the serial port between CPU and Arduino (in my case COM5). I have another external ArduinoNANO connected to USB.
    So in my app (developed in .NET) I detect three ports, COM1, COM5 and COM6. I have both NANO and onboard Leonardo programmed as simple serial echo and my app is periodically polling for response from Arduino. Everything works as expected from COM1 (Rx and Tx pins 5 and 7 are simply bridged for testing) and COM6, except when trying to get response from COM5.

    Now strange thing is, that using TeraTerm or RealTerm I'm getting normal response also from COM5, with the same settings (in all of them HW handshaking is disabled - but anyway - enabling in various combinations has no effect).

    I thought the problem is in my app, but further I tried also app "Simple Serial Port Monitor" with no response from COM5 only.

    I wouldn't write here not being at the top of my patience level after two days of digging just this.

    At the end, please do not suggest to use firmata, because I'm developing a SW, that will be used primarely in other platforms. I have choosen LattePanda because of onboard IO, so I don't need any external circuits to acquire some analog values.

    Please help me with your experience - at the end I'm sure there is just a tiny catch, that I overlooked somewhere. I'm just hoping, I won't be forced to use that external NANO.

    Thank you.
    Last edited by TehnikaMaori on Thu Jul 16, 2020 4:24 pm, edited 1 time in total.

    User avatar
    Posts: 2
    Joined: Fri May 15, 2020 4:09 pm

    Thu Jul 16, 2020 4:23 pm

    Since I had no luck with any straight solution, and obviously the issue is beyond someone else's experience, I had no other choice than to make a workaround.
    So the solution is to use Arduino's Serial1 (D0 and D1 pins) on Leonardo and adapt its' TTL levels to CPU's UART0 1,8V logic.
    System COM1 is accessible by any app, so now data are getting exchanged without any issue.

    Post Reply