Can't boot Lattepanda V1 (red LED on)

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:

    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Posts: 29
    Joined: Tue Apr 26, 2016 10:21 am

    Thu Jun 18, 2020 7:23 pm


    I bought Lattepanda V1 4/64 for a long time, threw it in a box, now I decided to get it and everything broke :<

    I booted up Windows and used it for about 5 minutes (with a 7 "screen) and then it went out and now does not want to boot anymore. When the power is connected, the red light turns on and remains on, the blue one blinks and stops.

    If I press the power button, nothing happens neither through HDMI nor through the 7" screen. The connected keyboard does not respond. No lights (num lock and etc) on it light up.

    Then I tried to change a power supply to Apple’s 20W, I have a tester and it gives out a 5V 2A board. Nothing changed.

    Seeing similar problems on the forum, I flashed the BIOS "DF-BI-7-S70CR110-C45B-001-B" through the programmer, it did not help. I also tried pressing the “hard reset” combinations (two close white side buttons like power and reset?) 10 times and it doesn’t seem like something was different from just turning it on and it didn’t help. :roll:

    Any help?

    User avatar
    Site Admin
    Posts: 2642
    Joined: Wed Jan 20, 2016 9:09 am

    Fri Jun 19, 2020 2:44 am

    Hi Tolsi,

    Can you send us a picture of your display connection? Did you flash BIOS successfully?
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Posts: 29
    Joined: Tue Apr 26, 2016 10:21 am

    Fri Jun 19, 2020 4:30 am

    > Can you send us a picture of your display connection?

    There is nothing special to show here. I used a 3D printed frame for the screen and the board was fixed at the back. Now I'm just testing it from HDMI to my TV

    > Did you flash BIOS successfully?

    Yes, it took about two hours to read and write/validate, I used CH341A with a special clothespin for the chip, it was very simple. There are differences between the old and the new BIOS dumps, but they both look similar.

    BTW I used a Windows virtual machine in Mac OS X for firmware and maybe that’s why it took so long. Now I will try to flash "Auto power ON BIOS" on a Windows machine.

    PPS This time it took 5 minutes. Anyway, nothing with HDMI and LCD. The red light is on all the time (even when I was flashing the chip), the board heats up and shows no signs of life.

    When powered by microusb, it consumes 5.15v / 2A, and there're only 4.77V on the CN2 connector. Perhaps this is not enough?

    Also, I tried to power it using CN2 port (like, at first it seems as if the board is initializing (the red LED is on, the blue LED flickers smoothly), then the red and blue LEDs starts abruptly as if it is a short circuit, but I am sure that the contact is correct. Maybe I have a bad voltage regulator, it works from USB, does not give out enough current and sags under load.
    photo_2020-06-19 07.24.52.jpeg
    photo_2020-06-19 07.24.52.jpeg (110.04 KiB) Viewed 618 times
    photo_2020-06-19 07.24.50.jpeg
    photo_2020-06-19 07.24.50.jpeg (134.56 KiB) Viewed 618 times
    photo_2020-06-19 07.24.47.jpeg
    photo_2020-06-19 07.24.47.jpeg (74.12 KiB) Viewed 618 times
    photo_2020-06-19 07.24.35.jpeg
    photo_2020-06-19 07.24.35.jpeg (118.76 KiB) Viewed 618 times
    photo_2020-06-19 07.24.32.jpeg
    photo_2020-06-19 07.24.32.jpeg (98.77 KiB) Viewed 618 times

    User avatar
    Posts: 29
    Joined: Tue Apr 26, 2016 10:21 am

    Mon Jun 29, 2020 7:39 am

    Any ideas?

    User avatar
    Site Admin
    Posts: 2642
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Jun 30, 2020 6:53 am

    Hi Tolsi, it seems like some circuit issue. pls contact for repair.
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply