And another Red LED Blinking

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Theredmc
    Posts: 1
    Joined: Mon Jun 22, 2020 8:55 am

    Mon Jun 22, 2020 9:18 am

    I make it quick
    Iam from Germany and I bought an Lattepanda 4/64gb for more than 200€ after 3 month it stoped working and I read flash the bios flash the bios whatever
    I did reflash the Bios I did replace the Bios Chip but the Red Led is still blinking and I only used the original Lattepanda Power supply.
    This cant be you sell a damn Mini Intel atom board which has this problem since his release !!
    Apple did the same thing with their butterfly Keyboard but they did replace it for free! Great now I can buy me another one at least an alternative


    So I need an Datasheet @Lattepanda Thankyou

    User avatar
    LattePanda
    Site Admin
    Posts: 2640
    Joined: Wed Jan 20, 2016 9:09 am

    Tue Aug 11, 2020 9:51 am

    Hi Theredmc
    I suggest you contect with techsupport@lattepanda.com and ask help. Please share more detail with picture or video. That help us to figure out the problem and provide the solution.
    Enjoy Tinkering with LattePanda ! :lol:

    Post Reply