wifi issues

If you're having trouble with your LattePanda, here's the place to get help.
Forum rules
    Post technical issues here.

    - Discussion tone should be kept polite and focused on facts
    - Vulgar language or flaming constitutes an instant ban
    - Please note we cannot support PM requests for help
    - Members are asked to post in English only so that posts can be well received and properly monitored
    - You can find the RMA guide [here]
    - Please check if your question has already been answered before opening a new thread. If it has not, please verify the following:


    - Have you tried a hard reset?
    - Are you using a 5V@2A+ power supply and a high quality USB cable?
    - Have you tried powering the board through the CN2 headers?
    - Have you tried a cooling solution such as a fan or heatsink?
    - Have you tried reinstalling drivers?
    - Have you tried reloading the operating system?
    - Have you tried flashing the BIOS?
    - Are you able to flash the BIOS at the hardware level?

    If you have not found a solution, post a new issue. To speed up the process please let us know:
    - Have you tried the solutions listed above?
    - What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
    - Have you tried any other solutions?
    - How long have you had your board for?
    - When did you first boot your board?
    - Did it work ok before the issue occurred or has the issue always been there?
    - Use images and videos to help us understand the issue where possible

    If you are seeking RMA:
    - Please open a new topic rather than hijacking someone else's thread
    - Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
    - Completed RMA cases will be marked with [CLOSED]
    You can find the RMA guide [here]

    Resolved Issues
    - If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
    - If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.

    What does troubleshooting support?
    - Hardware queries
    - Hardware issues that weren’t caused by you, e.g DOA board
    - Windows 10 specific issues
    Post Reply
    User avatar
    Optimum-Fireworks
    Posts: 11
    Joined: Wed Feb 07, 2018 2:38 pm

    Fri Feb 09, 2018 9:39 pm

    Hi All

    I now have two LattePandas, both the 2/32 and 4/64

    both are struggling with a weird wifi issue

    I've updated all windows 10 through Ethernet to my home network and it works fine by cable

    both LP will connect happily to my phones personal hotspot

    both LP will connect to a friends wifi next door and show errors when using the incorrect password

    Neither will connect to my home wifi in any way, both of them exhibit the same issues which don't appear at any other times.

    When selecting the network from the pop up it allows me to put in the password and set it to public, it then processes a few moments (2-10s) the whole pop up screen disappears, reappears and continues processing, it then eventually (5-30s) says "Can't connect to this network" , it does exactly the same if the password is incorrect (no notification this time to say the password is incorrect)

    Ive reset my router, reinstalled the firmware, changed the wifi name and password, tried no security, uninstalled the network drivers and reset the LP, tried other drivers, tried a massive wifi antenna (which lets me have wifi from 10 doors away!). Everything else connects to my wifi perfectly but the latte pandas.

    Ive not got a clue unless my router is simply not compatible but I cant see how as its just WIFI!

    router is a Netgear WGT624 v3 updated with the V2.0.25_1.0.1NA american firmware (I'm in the UK) and obviously running Win 10

    User avatar
    Optimum-Fireworks
    Posts: 11
    Joined: Wed Feb 07, 2018 2:38 pm

    Fri Feb 09, 2018 9:46 pm

    Also just discovered the hotspot works fine from the LPs when connected to ethernet

    User avatar
    leogx9r
    Posts: 36
    Joined: Tue Dec 05, 2017 1:09 pm

    Thu Feb 15, 2018 3:50 am

    Clearly a Wifi driver issue. I'd recommend you try:

    - Tweaking the WiFi settings.
    - Reinstalling the WiFi driver.
    - Reinstalling Windows. ( Probably will lead to the same result as #2 above. )

    User avatar
    Optimum-Fireworks
    Posts: 11
    Joined: Wed Feb 07, 2018 2:38 pm

    Fri Feb 23, 2018 12:28 pm

    I've tried everything I can think of and find to adjust the wifi settings but as it works with literally every connection i find BUT for my home network it would appear its workign fine just unable for some reason to make a connection there.

    I've tried updating and rolling back drivers

    I've reinstalled windows twice on it and no difference, even tried XP too

    User avatar
    LattePanda
    Site Admin
    Posts: 2640
    Joined: Wed Jan 20, 2016 9:09 am

    Thu Mar 01, 2018 3:23 am

    Hi, how's everything going.
    Sincerely sorry for the delay getting back to you.
    Could you please tell us whether the wifi works before?
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Optimum-Fireworks
    Posts: 11
    Joined: Wed Feb 07, 2018 2:38 pm

    Tue May 29, 2018 4:43 am

    Had to get a new router for home.

    No idea why but my original router simply would not allow wifi to work on just the latte pandas

    User avatar
    LattePanda
    Site Admin
    Posts: 2640
    Joined: Wed Jan 20, 2016 9:09 am

    Tue May 29, 2018 11:24 am

    So the LattePanda can works with the new router?
    Enjoy Tinkering with LattePanda ! :lol:

    User avatar
    Fryda
    Posts: 3
    Joined: Wed Nov 21, 2018 7:40 pm

    Mon Nov 26, 2018 6:54 pm

    Also make sure your network is set to private and not public

    User avatar
    dariv
    Posts: 1
    Joined: Wed Jul 01, 2020 11:45 am

    Wed Jul 01, 2020 11:51 am

    Exact same issue here. Will not connect to netgear nighthawk router. If I change the wifi adapter settings, like antenna diversity, it connects but with a poor connection. The signal however is very strong. It's something with the wifi adapter settings on the LP

    Post Reply