Beta Ubuntu Image for LattePanda - Official version

General Info and Announcements from the LatteTeam and Distributors
User avatar
eddieparker
Posts: 2
Joined: Fri May 24, 2019 2:11 pm

Wed May 29, 2019 6:11 am

I've had no luck with this image. I've bought a series of 4/64 Lattepanda's and tried: the clonezilla succeeds, and then it reboots, I get the Lattepanda splash screen, my monitor gets no HDMI signal and it looks like the device never boots up properly -- my router doesn't report it leasing an IP so I can't even ssh into it.

Has anyone else had similar issues that can explain what I have to change? I'd really like to avoid returning these. :/

(Hrmm, I just reset the BIOS to factory defaults and now it reboots and hangs at a LATTEPANDA splash screen and doesn't seem to be progressing. Not sure if that's better or worse!)

Any tips would be appreciated!

-e-

User avatar
pedrorodrigues
Posts: 1
Joined: Thu Jul 25, 2019 5:23 pm

Sat Jul 27, 2019 4:39 pm

Hello,


I need to use the LP with touch screen and an hdmi Monitor. With this Ubuntu image I can have them work but to be able to get image on both displays i need to unplug hdmi cable on boot. Otherwise the 7" DSI display goes blank. This case is not practical because forces one person to unplug / plug the hdmi cable every start or reboot.

I've installed Debian 10 w 4.19 kernel successfully and it solves the Displays Problem but now the Goodix Touch does not work.
Can you tell what changes or configurations have made to get the touch to work?

From the command history used in your official image i think you change the goodix / gt9xx kernel module. If so can you make the source code available?

User avatar
LattePanda
Site Admin
Posts: 2446
Joined: Wed Jan 20, 2016 9:09 am

Tue Jul 30, 2019 5:54 am

pedrorodrigues wrote:
Sat Jul 27, 2019 4:39 pm
Hello,


I need to use the LP with touch screen and an hdmi Monitor. With this Ubuntu image I can have them work but to be able to get image on both displays i need to unplug hdmi cable on boot. Otherwise the 7" DSI display goes blank. This case is not practical because forces one person to unplug / plug the hdmi cable every start or reboot.

I've installed Debian 10 w 4.19 kernel successfully and it solves the Displays Problem but now the Goodix Touch does not work.
Can you tell what changes or configurations have made to get the touch to work?

From the command history used in your official image i think you change the goodix / gt9xx kernel module. If so can you make the source code available?
Ubuntu image: Have you reflashed the Bios for Ubuntu system? According to our tests, your display problem could be solved after reflashing the BIOS.
please check our tutorial of Ubuntu installation.
http://docs.lattepanda.com/content/1st_ ... u-1604-lts

Debian: we also do not have better solution for the touch panel. We suggest you use our official Linux image.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
bart_bart
Posts: 1
Joined: Mon Sep 09, 2019 5:03 pm

Tue Sep 10, 2019 5:27 pm

LattePanda wrote:
Tue Jul 30, 2019 5:54 am
Ubuntu image: Have you reflashed the Bios for Ubuntu system? According to our tests, your display problem could be solved after reflashing the BIOS.
please check our tutorial of Ubuntu installation.
http://docs.lattepanda.com/content/1st_ ... u-1604-lts

Debian: we also do not have better solution for the touch panel. We suggest you use our official Linux image.
If you have some changes for the touch panel - please share them.

From what i see in the image there is an out of tree built kernel - so sharing the patches should be an easy thing.

I also would like to remind that the changes for kernel should be shared, as not sharing them is an GPLv2 violation.

And frankly, I dont want to run an untrusted kernel with unknown patches inside - think what message this sends to the community.

Post Reply