LattePanda Alpha can not power on

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
wureka
Posts: 3
Joined: Sat Mar 02, 2019 2:10 pm

Sun Aug 11, 2019 6:52 am

Hi,
Today I found that my LattePanda Alpha 864 can not power on.
I used the original USB TYPE-C power supply provided by LattePanda.
When I connect the power supply, no red/blue LED blink.
I have no extra power supply for testing which part (LattePanda Alpha or power supply) is malfunction.
Could I mail the LattePanda Alpha 864 and its power supply to you for checking/repairing ?

Thank you for your help.

User avatar
rckrchrdsn
Posts: 6
Joined: Fri Aug 17, 2018 3:17 am

Sat Aug 17, 2019 4:02 am

I have a Delta doing the same thing. When I received it, the proper leds lit up and I booted. I left it on and came back 5 hours later and it was off. removed the plug from the Delta and replugged it. no power led. Tried two alternative PD that are working and supply up to 5A. No power LED.

User avatar
ccs_hello
Posts: 441
Joined: Sat Oct 13, 2018 9:16 pm

Sat Aug 17, 2019 5:07 pm

Try the 4-pin DC power in method.
This seems to be more reliable than the USB-C PD type of power supply arrangement.
(There are DIY info in this forum...)

Post Reply