Cannot install full Intel graphics driver

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
gwynethh15
Posts: 6
Joined: Tue Mar 13, 2018 1:47 pm

Tue Oct 29, 2019 1:07 pm

After a series of problems we needed to install Win10 from a MS media thumb drive. After several reboots we have all drivers installed except the full Intel graphics driver which we need to correct over scan on our display. Device manager show the 2018 MS driver for the UDH 600 graphics adapter. We cannot get the full Intel update to install (via Intel Driver and Support Assistant). Attempting to install the driver results with the message "The driver being installed is not validated for this computer..." and installation terminates.

Any hints to get the full Intel driver with over scan correction reinstalled? (This worked before our problems). TIA.

L/P Delta.

User avatar
gwynethh15
Posts: 6
Joined: Tue Mar 13, 2018 1:47 pm

Tue Oct 29, 2019 6:17 pm

Solved. Had to remove the device, re-scan hardware, accept MS standard graphics controller, install the Intel driver AND after a reboot manually select the Intel driver and reboot again. Ended up with TWO Intel 600 devices but removed one. What a pain. Now have corrected the over scan.

Post Reply