Latte Panda Defective - No Lights

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
bjamieson
Posts: 1
Joined: Mon Nov 11, 2019 4:50 pm

Wed Nov 13, 2019 11:48 am

Hi,

My Latte Panda 846s has been excellent as a headless Win X weather station for ~ 3 months. A few days ago it went off-line, and I discovered that it was powered down.

This has happened before now, and I thought it was due to a windows upgrade trying to do an auto restart, and perhaps failing. At that point I was able to press the powerbutton and get it to reboot correctly.

This time, the device has no activity lights showing up, and despite verifyig that the Latte Panda supplied power supply can charge batteries and phones etc, it does nothing for the board. Also, trying the only other usbC powersource I have (for a Raspberry Pi v4), it too does not power the Panda.

Both supplies do power the Raspberry Pi correctly.

The device was bought 4 months ago, and took about 6 weeks to get to the Falkland Islands.

I hope this can be resolved or replaced, 4 months at £100 per month (including shipping time) is not a good thing !

Thanks,

Brian

User avatar
ccs_hello
Posts: 440
Joined: Sat Oct 13, 2018 9:16 pm

Thu Nov 14, 2019 3:02 pm

USB-C has multiple setting options and is really complicated. Your method to troubleshoot is not the correct way.
My suggestion is https://www.lattepanda.com/topic-p31654.html#p31654

User avatar
RDCWizard
Posts: 2
Joined: Tue Nov 06, 2018 1:08 am

Thu Nov 28, 2019 3:45 pm

Briefly Shorting out the two pins on the Connector labeled SW next to the Red LED on my Lattepanda Alpha brings it back to life.
Hope this works for you.

User avatar
msrego
Posts: 4
Joined: Sun Nov 24, 2019 4:10 pm

Thu Dec 05, 2019 5:00 pm

Hello. I also had the no LEDs symptom, and I traced it back to a shorted to ground ceramic capacitor. Try to measure the resistance of the output and decoupling capacitors of the DC/DC converters. Anything less than 7 ohm will indicate an probable short circuit.

Don't forget that the capacitors for the CPU core voltage DC/DC converters have naturally very low resintance (10 to 7 ohm) due to the huge current demand of the CPU. Using a continuity checker might trigger the buzzer, and falsely lead you to believe to the presence of a short.

If you need any more help, be free to contact me.

Post Reply