DEFECTIVE Alpha 864 blue light flashes, then nothing

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 2
Joined: Sat Dec 29, 2018 2:39 am

Sun Dec 30, 2018 5:37 am

Indiegogo order number 170
forum alias: TimHays

I just received my Alpha 864 yesterday, was excited to get it finally, put it in the Titan case, plugged-in the touch-screen, plugged-in the power, and was extremely let down when I have arrived at the conclusion that my system is DOA!!!
The blue light flashes every 4 seconds or so, but nothing happens when I press the button to power it on.
I am very aware and careful about static and I never touched any contact surfaces, so I am sure that I didn't cause any issue on my end.
I looked over the other solutions in this thread and I do not have another USB-C PD power supply to try.
I've plugged it in again today and the same thing happens, with blue light flashing but not booting up when power button is pressed.

I'm not sure how your testing facility can claim that these are triple checked when so many of them arrive not working.
Also, you're only offering a 90 day warranty? For a product with this many failures? How do you expect people to have any confidence in your products?

Alpha 864 /w Win10 Pro Bundle
Estimated delivery: June 2018
1x LattePanda Alpha with 8G RAM, 64GB eMMC, activated Windows 10 Pro + Streaming cable + 7 inches Touch Display + Titan Case
1 x LattePanda Alpha 864
1 x Streaming cable
1 x 7 inches Touch Display
1 x Titan Case
1 x 42Watt USB-C PD Wall Adapter
1 x Ultra-thin Cooling Fan
$439.00 USD
Subtotal $439.00 USD
Shipping (United States) $22.00 USD
Total paid $461.00 USD

User avatar
Site Admin
Posts: 2642
Joined: Wed Jan 20, 2016 9:09 am

Mon Jan 07, 2019 11:45 am

Dear Tim,

We've been testing the products for at least twice with full testing. So DOA should not be possible. Could you please share more about your location or delivery info you can check? And did you try to power the device again to see if it works?

If you've tried everything, please contact with the support team following this -
We will collect every faulty units back to us to see what's going on when shipping or any other potential problem.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
Posts: 3
Joined: Thu Jan 31, 2019 8:48 pm

Thu Jan 31, 2019 8:54 pm

I have the same issue, my solution is to unplug the IPS display unit and my DF13 light comes on and I can start it after a few seconds...

Wonder how I can get the display to work properly...

User avatar
Posts: 623
Joined: Sat Oct 13, 2018 9:16 pm

Thu Jan 31, 2019 9:35 pm

LCD display panel for LP Classic and for LP Alpha are different types (MIPI-DSI vs eDP respectively) and cannot be used interchangeably.

User avatar
Posts: 3
Joined: Thu Jan 31, 2019 8:48 pm

Sun Feb 03, 2019 1:14 pm

ccs_hello wrote:
Thu Jan 31, 2019 9:35 pm
LCD display panel for LP Classic and for LP Alpha are different types (MIPI-DSI vs eDP respectively) and cannot be used interchangeably.
Thank you. That would have been nice to know when I preordered... I guess I will have to order a few new ones then.

User avatar
Posts: 22
Joined: Fri Apr 15, 2016 9:29 pm

Mon Feb 04, 2019 2:36 am

Are you just pressing the power button or holding it from a few till the light comes on stable? Holding the power button for a few is normally how I start both the 1st Lattepanda and the Lattepanda Alpha.

Post Reply