eMMC hardware error on LattePanda Alpha

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
tommytyker
Posts: 2
Joined: Sat Jan 05, 2019 7:50 am

Sat Jan 05, 2019 7:53 am

OS: Ubuntu 18.04 LTS
Boot drive: eMMC 64GB
Board: Latte Panda Alpha 8/64

After booting dmesg, shows me the following message in an almost continual loop.
[ 412.372751] mmc1: Timeout waiting for hardware cmd interrupt.
[ 412.372756] mmc1: sdhci: ============ SDHCI REGISTER DUMP ===========
[ 412.372760] mmc1: sdhci: Sys addr: 0x00000000 | Version: 0x00001002
[ 412.372764] mmc1: sdhci: Blk size: 0x00000000 | Blk cnt: 0x00000000
[ 412.372768] mmc1: sdhci: Argument: 0x00000c00 | Trn mode: 0x00000000
[ 412.372771] mmc1: sdhci: Present: 0x000a0001 | Host ctl: 0x00000001
[ 412.372775] mmc1: sdhci: Power: 0x0000000e | Blk gap: 0x00000080
[ 412.372779] mmc1: sdhci: Wake-up: 0x00000000 | Clock: 0x0000e8c7
[ 412.372782] mmc1: sdhci: Timeout: 0x00000000 | Int stat: 0x00000000
[ 412.372786] mmc1: sdhci: Int enab: 0x00ff0043 | Sig enab: 0x00ff0043
[ 412.372790] mmc1: sdhci: AC12 err: 0x00000000 | Slot int: 0x00000000
[ 412.372793] mmc1: sdhci: Caps: 0x7568c881 | Caps_1: 0x00000807
[ 412.372797] mmc1: sdhci: Cmd: 0x0000341a | Max curr: 0x00000000
[ 412.372801] mmc1: sdhci: Resp[0]: 0x00000000 | Resp[1]: 0x00000000
[ 412.372804] mmc1: sdhci: Resp[2]: 0x00000000 | Resp[3]: 0x00000000
[ 412.372807] mmc1: sdhci: Host ctl2: 0x00000000
[ 412.372811] mmc1: sdhci: ADMA Err: 0x00000000 | ADMA Ptr: 0x0000000000000000
[ 412.372813] mmc1: sdhci: ============================================

User avatar
Boring
Posts: 88
Joined: Sat Apr 16, 2016 7:14 pm

Sun Jan 06, 2019 2:32 pm

Sdhci is your SD card reader. Insert an SD card and your error is gone. I had the same in Debian 9.6.

User avatar
daidai
Posts: 2
Joined: Sun May 05, 2019 9:20 pm

Tue May 07, 2019 7:22 pm

Boring wrote:
Sun Jan 06, 2019 2:32 pm
Sdhci is your SD card reader. Insert an SD card and your error is gone. I had the same in Debian 9.6.
But this does not work when you need to replace the sd card. When you pick out the card and the error comes out, then the card reader stop working until you reboot the system.

Post Reply