SD-Card Problem

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
T1g_i
Posts: 7
Joined: Thu Jan 03, 2019 6:09 pm

Mon May 20, 2019 8:50 am

Hello,

I have a big problem.
I want to enable the scc sd card support.
But everytime I save the options and restart my Lattepanda Delta, it is still disabled.
Why?

Thanks,
T1g_i

User avatar
ccs_hello
Posts: 754
Joined: Sat Oct 13, 2018 9:16 pm

Mon May 20, 2019 11:49 am

re: the BIOS setting does not survive a power removal cycle (assuming that is the actual scenario)

The new LP Delta (assuming recent Alpha will be similar) is not shipped with the 3V lithium CR927 backup battery.
If that is the case, please get a CR927 (ebay or amazon have some cheap ones) battery and insert it into the empty slot.
<-- note the polarity (the metal battery clip has a "+" symbol on it, which should go with the flat side of the CR927 (which also has a "+" symbol)

User avatar
T1g_i
Posts: 7
Joined: Thu Jan 03, 2019 6:09 pm

Fri May 24, 2019 8:45 am

I set the option, restart the Delta, go into the bios and the option is still disabled.
Any other option is still set. But the sdcard option is everytime disabled.

User avatar
SixSixSevenSeven
Posts: 25
Joined: Sun Sep 04, 2016 7:27 pm

Fri May 24, 2019 8:47 pm

ccs_hello wrote:
Mon May 20, 2019 11:49 am
re: the BIOS setting does not survive a power removal cycle (assuming that is the actual scenario)

The new LP Delta (assuming recent Alpha will be similar) is not shipped with the 3V lithium CR927 backup battery.
If that is the case, please get a CR927 (ebay or amazon have some cheap ones) battery and insert it into the empty slot.
<-- note the polarity (the metal battery clip has a "+" symbol on it, which should go with the flat side of the CR927 (which also has a "+" symbol)
Every other BIOS setting survives power cycling without the battery. Hell, they even persist through complete disconnection of power supply. BIOSes havent had battery backed settings for a decade.

User avatar
ccs_hello
Posts: 754
Joined: Sat Oct 13, 2018 9:16 pm

Sun May 26, 2019 1:51 am

T1g_i wrote:
Fri May 24, 2019 8:45 am
I set the option, restart the Delta, go into the bios and the option is still disabled.
Any other option is still set. But the sdcard option is everytime disabled.
Yes, I can confirm this behavior but don't know the reason why it is done that way.
I.e., In every bootup stage, such "SCC SD Card support" feature will always be disabled.
SCC (Storage Control Cluster) D27:F0 somehow was not able to be enabled/turned on.

Post Reply