[DEFECTIVE] LattePanda Alpha 864s - No HDMI signal output

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
menelkiner
Posts: 1
Joined: Tue Dec 24, 2019 1:30 am

Thu Dec 26, 2019 4:21 pm

I recently picked up a LattePanda Alpha 864s that I use as a media server and for light desktop use.

The board has started to not output an HDMI signal for unknown reasons. I have not tried tinkering with the BIOS or any other settings. It was working perfectly, then one morning it just wasn't.

The board itself seems to act normally, red LED pulses when power is applied then goes solid with intermittent blue flashes. Pushing the power button seems to boot the device normally, the blue LED goes solid and stays on with the red LED. There is just no video signal coming out of the board.

I am using the supplied charger, and have tried other high-powered supplies with no effect.
No combination of cables or different monitors yields a positive result, I just get "no signal" or "check signal cable" warnings on the screens.

I have tried hard reset as outlined here:
http://www.lattepanda.com/forum/viewtop ... f=10&t=853

I have tried reinstalling the OS:
http://docs.lattepanda.com/#How_to_re-i ... ows_system

I have tried flashing the bios:
https://github.com/LattePandaTeam/Latte ... ha%26Delta

I have also tried removing the RTC battery then booting, with no effect.

I do not own or have access to an eDP display that uses the ribbon connector so check if HDMI out is the only issue.
I do not own or have access to hardware to try flashing the BIOS at a hardware level.

I am open to further suggestions to try and breathe life back into this SBC.
It was a perfect product for me and I was considering getting a second before this happened.
At this point, the only option I see is getting an RMA and hoping it can be fixed...

User avatar
LattePanda
Site Admin
Posts: 2628
Joined: Wed Jan 20, 2016 9:09 am

Fri Dec 27, 2019 2:46 am

Sounds like the faulty HDMI port issue. Please help find another HDMI cable or HDMI screen to test again. Since you do not have eDP display to test, please contact our techsupport@lattepanda.com for more help.
Enjoy Tinkering with LattePanda ! :lol:

Post Reply