[DEFECTIVE] LattePanda startup issue / RMA request

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
M100FAT
Posts: 2
Joined: Mon Dec 09, 2019 12:51 pm

Mon Jan 06, 2020 10:38 am

Dear Lattepanda support,

This post is regarding a LattePanda Alpha M3-7Y30, 8GBRAM

It has worked well before I flashed the bios.
It started with reflashing the bios to get auto power on working. Something must have gone wrong there since it did not want to start after the reflash.

The lattepanda would not boot anymore and when given power it wouldn’t even show any leds. I tried powercycling, flushing, the power+reset button fix, but no results.

Now however I’ve been able to get to the bios through a USB bios programmer and install the default bios again. Odd thing is it still didn’t work. Nothing, not even a red light when powered. And yes I have tried the powerbutton + reset button combo many times.

I’ve searched some more and read somewhere that sometimes removing the RTC battery for a longer period of time could help. So I removed it, after about 1,5 – 2 hours I decided to try it again. At first nothing, but after a while the blue light came on (instead of the red) then the red, then it would act as if the powercable had a cable break somewhere (but this does not seem to be the case when testing with other pandas), flashing and dimming in a seemingly random way. Then it would stabilise on red. So I decided to push my luck and try to start, to my amazement it worked. It booted to windows no problem. Happy I shut it down and reïnstalled the RTC battery thinking everything was fixed. But after installing the RTC battery again it wouldn’t start just like before, no led. I felt like I was frustratingly close to getting it to work again, but I had no idea why or how.

I’ve tried letting it lie without RTC battery again, and this time I got a weak blue flash that dimmed and then nothing.

The next day still nothing, so I decided I would check again with the bios programmer, there was still data on the bios, but it didn’t match what it should be.
(yes I have checked the RTC battery and yes it gave the expected voltage)

After a lot of trying and reprogramming the bios with a bios programmer once again it randomly started up again, but this time I noticed I had my finger pressed to the back of the pcb, tried it again without finger, nothing, tried it again with finger and it worked again. Now when power stays connected I can shut it down, restart it, everything works. But if the power has been disconnected the first time I want to start it I have to press my finger to that spot.
When starting with my finger on the right spot (on the backside of where the power from the adaptor enters the PCB) it will start with flashing the red led, then after a while it will stabilize and the red led will stay on and the blue light flashes occasionally (like it normally would). Once the red led has stabilized I can remove my finger and start the lattepanda.

It would seem this issue starting it does not lie with the BIOS and is due to hardware failure, therefore I would like to start an RMA procedure.

Sincerely,

Maarten Huizing,

P.S. Thanks to the lattepanda team for reacting quickly to my email to have my account activated.

User avatar
LattePanda
Site Admin
Posts: 2523
Joined: Wed Jan 20, 2016 9:09 am

Tue Jan 07, 2020 3:08 am

Hi M100FAT, can you take a pic and mark the "finger area"? It seems some component is faulty.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
M100FAT
Posts: 2
Joined: Mon Dec 09, 2019 12:51 pm

Tue Jan 07, 2020 9:24 am

The circle below shows the area I need to touch with my finger.
LattePandaAreaLQ.png
The area where I need to put my finger for startup
LattePandaAreaLQ.png (346.42 KiB) Viewed 2448 times

User avatar
ccs_hello
Posts: 549
Joined: Sat Oct 13, 2018 9:16 pm

Tue Jan 07, 2020 3:50 pm

That area is the MOSFET/control side of USB-C (in this context power-feeding the LPA) parts
(while the opposite side is the USB-C PD controller.) Issues on this (or USB-C connector contacts will definitely cause power problems. Suggest using DC 4-pin powering method. It is more reliable anyway.

Post Reply