BIOS secure boot & BIOS refresh using U disk

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 1
Joined: Thu Jan 16, 2020 2:39 am

Fri Jan 17, 2020 4:42 am

Hi, I purchased LP 864s a few days ago. And I'm trying to set up NVMe-based eGPU in ubuntu 16.04.

But, there are some issues.
(1) In the process of installing and setting up nvidia-driver 2070 eGPU, I need to change secure boot to disable mode. But, in BIOS setting, there is no option for setting up secure boot. Moreover, when I tried to change the secure boot to disable mode using command line in ubuntu, the system said that "secure boot is not supported."

(2) For this reason, I tried to refresh my LP's BIOS through this URL ( ... 20m3-8100y).
But, the files provided by the above URL (github) are not enough to refresh BIOS (LP alpha 864s).

So, to sum up my question, can I set secure boot to disable mode? If not, are there any references or guidelines for setting up eGPU driver on ubuntu?
Finally, how do I refresh the 864s's BIOS using U-disk? It appears that the provided .zip file is small in size and insufficient in content.
img.jpg (544.24 KiB) Viewed 4801 times

Post Reply