RMA [DEFECTIVE] No more signs of life

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 3
Joined: Tue Jun 07, 2016 5:44 pm

Tue Feb 04, 2020 8:09 am


my LP Alpha (backer#316) received almost 1 year ago, but used very few, yesterday it stopped working without any particular reason.
It was running with at low cpu level, when it stopped I was not present, when I realized that the board was switched off I have tried to turn it on, but no lights were present anymore.
Pushing the power button nothing changed, I have tried to check if the power supply was off, but connecting other devices to it, it charged correctly.

On the board there are no signs of shot circuit at all and no burning smell is detected.
Let me know what should i do to try to revive or to send it back to you to be repaired.
Kind regards

LattePanda Alpha back.jpg
LattePanda Alpha back.jpg (1.48 MiB) Viewed 2431 times
LattePanda Alpha up.jpg
LattePanda Alpha up.jpg (511.16 KiB) Viewed 2431 times

User avatar
Posts: 631
Joined: Sat Oct 13, 2018 9:16 pm

Tue Feb 04, 2020 9:57 pm

re: check if the power supply was off, but connecting other devices to it, it charged correctly.

Not a valid test. LP Alpha negotiate with the USB-C power supply in PD mode and requires 15V 3A negotiation step's success.
(Can try a working power supply in the forum list instead.)

If no BLUE nor Red LED light at all, try remove the Lithium battery trick. Also change to 4-pin DC powering method. That method is much more stable.
Few threads here had discussions on those topics.

Post Reply