Usb Port doesn’t work

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
User avatar
kasek
Posts: 28
Joined: Sat Dec 14, 2019 7:48 pm

Sun Nov 01, 2020 5:13 am

ender wrote:
Wed Oct 21, 2020 5:20 am
kasek wrote:
Tue Oct 20, 2020 4:01 am
I had same problem had to send it back for warranty. Be warned shipping cost is on your dime, they will only reimburse a small amount and what they do reimburse is store credit only. I was not informed of that when I sent mine in
What is the repair they do on your motherboard?
I think they replaced the USB port but I’m not 100% sure

User avatar
ender
Posts: 134
Joined: Wed Dec 27, 2017 3:55 pm

Tue Nov 24, 2020 9:56 am

have a nice day,
Does this material affect the USB 2.0's on the device not working?
What is the purpose of using this material?

https://www.onsemi.com/pub/Collateral/FDMC510P-D.PDF

picture;
https://www.mickmake.com/post/lattepand ... 0x360_.jpg

User avatar
ccs_hello
Posts: 664
Joined: Sat Oct 13, 2018 9:16 pm

Tue Nov 24, 2020 5:52 pm

It is a high-side MOSFET switch (I am guessing) to turn ON/OFF the USB port's DC power.
BTW, if ONLY that MOSFET is defective and everything else is okay, then the USB port will still work, if the USB peripheral device(s) is connected to a POWERED USB Hub, while that hub's upstream port is connecting to that (affected) USB port on the LattePanda side.

Post Reply