LattePandaAlpha not power on

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 1
Joined: Thu Aug 13, 2020 5:18 am

Thu Aug 13, 2020 5:43 am

my latte panda alpha works well last week.
but, It does not power on this week with nothing change configuration.
I found CR927 RTC battery is Low voltage.
so, replace it new one.

powerd by official 45w PD Power adapter .
Both Red and Blue led not lit.
I tried powered by 12V PH-4pin. does not led blink. no current consumption.
5V pin and 3.3V pinout seems 0V.
how can I solve this?
Is there any repair service?

User avatar
Site Admin
Posts: 2642
Joined: Wed Jan 20, 2016 9:09 am

Thu Aug 13, 2020 7:14 am

@j1okabe,pls send email to for further repair and RMA information.
Enjoy Tinkering with LattePanda ! :lol:

Post Reply