Component Identification: Problem in power input circuit

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
msrego
Posts: 9
Joined: Sun Nov 24, 2019 4:10 pm

Sun Aug 16, 2020 10:59 pm

Hello,

Unfortunately I had yet another problem which made my Lattepanda Alpha unbootable. After probing around, I isolated the problem to the area around the primary input MOSFETS and by sheer luck, touching component (0402 resistor?) circled in red in the attached picture made the red LED briefly light up, which made me realize that that component is making a bad contact.

By visual analysis under a microscope, the circled component appears to be cracked, thus the bad contact. If I apply continuous pressure on it, I am able to boot the board, and after boot I can release the pressure without any crashes / abnormal behavior, so it seems this component is only essential to the boot process.

Now, I need to replace that component, but as it is cracked I am unable to get a good reading and figuring it out myself, so I would be very grateful if anyone knows which component it is and its respective value, and is willing to share that information.
Attachments
IMG_20200816_212117.jpg
IMG_20200816_212117.jpg (1.65 MiB) Viewed 523 times

User avatar
ccs_hello
Posts: 623
Joined: Sat Oct 13, 2018 9:16 pm

Mon Aug 17, 2020 1:51 am

20K ohm resistor per my VOM in-circuit measurement.

User avatar
LattePanda
Site Admin
Posts: 2642
Joined: Wed Jan 20, 2016 9:09 am

Mon Aug 17, 2020 9:42 am

ccs_hello is correct.
It's RES 0402 20K OHM +/-1%
Enjoy Tinkering with LattePanda ! :lol:

User avatar
msrego
Posts: 9
Joined: Sun Nov 24, 2019 4:10 pm

Mon Aug 17, 2020 4:42 pm

Thank you very much for the always prompt replies.

After I get the 20k resistor and replace the cracked one I will report the status of the repair for future reference.

Post Reply