Arduino not Working on LattePanda Delta 432

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 1
Joined: Mon Aug 24, 2020 12:45 am

Mon Aug 24, 2020 12:51 am


I'm working on a project that uses LattePanda Delta connected to an Arduino Mega2560 for motor control. I've booted a Ubuntu 16.04 LTS OS on the LP. I'll be using OpenCV with Python as well in the future.

There are several issues regarding the communications between the LP and the Arduino. Some of them are:
- Arduino auto-detects the board as Arduino Leonardo, but is able to upload the code/sketch.
- Even though uploading went fine, the motors did not move.
- I've tried force-setting the board to Mega 2560, but it won't upload my sketches (Uploading failed)
- On my main computer (Windows 10), I was able to upload code to the Arduino Mega and make it move (auto-detect is showing Mega 2560)

My parameters:
- I've connected the DFRobot Quad Motor shield attachment to the Mega 2560 for 12v motor controls
- I'm doing most of my programming via VNC server to the LP board
- /dev/ttyACM0 port shows Arduino Leonardo instead of Arduino Mega 2560

I'd be happy to supply you with all the code, should you need them. Googling this problem seems to show little results.
Thank you for your time!

User avatar
Posts: 623
Joined: Sat Oct 13, 2018 9:16 pm

Mon Aug 24, 2020 1:16 pm

/dev/ttyACM0 is connected to the on-motherboard/built-in ATmega32u4 (Leonardo.)

Don't know how you connect the external Mega2560 board. Please use the proper communication port to the 2560 board.

Post Reply