Another dead Alpha?

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 1
Joined: Wed Sep 16, 2020 4:31 am

Wed Sep 16, 2020 5:36 am


I have an Alpha that was working perfectly that I was using as a bit of digital signage. Recently I came in and found the display blank.

When I tried to boot it, the red light would flash 14 times and the blue light would slowly flash. I tried hard resets, pulling the clock battery, wiggling the standard LPA power cable, crossing fingers, and all to no avail. It has yet to light up a display.

Am I correct that the default answer here is to go out and buy a BIOS programmer and reflash the BIOS!?

After reading the other posts in the forum I have a lot of outstanding questions:
Is the LED pattern an exact indicator of corrupted BIOS? It would seem that a flashing indicator that flashes a certain number of times on every boot attempt is trying to say something? Is there a doc anywhere?
Is this honestly expected (and accepted) behavior!? Does a booted and running device just randomly lose its BIOS? How is this not considered a major design flaw?
Can I do this via RMA? Is there any guarantee it won't happen again?

Thank you to everyone who has invested such detail in the reflash docs - Has anyone had to do it more than once?

User avatar
Site Admin
Posts: 2642
Joined: Wed Jan 20, 2016 9:09 am

Thu Sep 17, 2020 9:47 am

Hi tpaakki,if you never update BIOS on your Alpha, then it won't be BIOS issue. can you see Blue LED turn on when press power button? if your Alpha is still under warranty, pls contact for RMA instructions.
Enjoy Tinkering with LattePanda ! :lol:

Post Reply