USB Port Identification - 864s

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
Post Reply
User avatar
Posts: 9
Joined: Thu Feb 20, 2020 2:58 pm

Mon Nov 09, 2020 6:23 pm

When I try to identify the USB ports on my 864s, I get the following:

HS01 0x01
HS02 0x02
HS03 0x03
HS04 0x04
HS05 0x05
HS06 0x06
HS07 0x07
HS08 0x08
HS09 0x09
HS10 0x0A
USR1 0x0B
USR2 0x0C
SS01 0x0D
SS02 0x0E
SS03 0x0F
SS04 0x10
SS05 0x11
SS06 0x12

I've managed to identify that HS03, HS05, HS07 (USB2) and SS02, SS03, SS04 (USB3) are the three USB ports. What I'm really struggling to identify is the USB-C DP port identifiers. Not helped as I'm using it to power the device, but I really want to identify it so I can power from my monitor and also send video to it. Other identification would be great as well, but the USB-C is the one I REALLY care about.

Am hoping someone has figured this one out.


User avatar
Posts: 664
Joined: Sat Oct 13, 2018 9:16 pm

Tue Nov 10, 2020 7:57 pm

Plugging in a USB-C based device such as a flash drive...
If using Windows, use the application USBview to find that flash drive to get port assignment info.
If using Linux, use lsusb -vv

User avatar
Posts: 9
Joined: Thu Feb 20, 2020 2:58 pm

Wed Nov 11, 2020 12:09 pm

Hiya - Thanks for the reply. I've actually done this process which is how identified the USB2/3 ports. The issue I am having is with the USB-C DP port as I'm using it for power. I think I may have identified it as SS01 0x0D via using a powered USB hub. Will need to do some further testing to confirm, but this does seem to be the SS port for USB-C

Post Reply