Lattepanda Alpha 864 not powering trough USB-C but powering with 12V DC

If you're having trouble with your LattePanda Alpha & Delta, here's the place to get help.
Forum rules
If you have not found a solution, post a new issue. To speed up the process please let us know:
- Have you tried the solutions listed above?
- What board are you using? Standard (2GB RAM/32GB eMMC) or Enhanced (4GB RAM/64GB eMMC)?
- Have you tried any other solutions?
- How long have you had your board for?
- When did you first boot your board?
- Did it work ok before the issue occurred or has the issue always been there?
- Use images and videos to help us understand the issue where possible

If you are seeking RMA:
- Please open a new topic rather than hijacking someone else's thread
- Mark RMA posts with [DEFECTIVE] + <helpful description of issue>. We can then approve/disapprove each request
- Completed RMA cases will be marked with [CLOSED]
You can find the RMA guide [here]

Resolved Issues
- If you manage to fix an issue, please share your solution for the good of the community. It could help someone else in future.
- If an issue is resolved the thread should be marked as [RESOLVED]. We can then sticky the thread to help people in future.
User avatar
ccs_hello
Posts: 740
Joined: Sat Oct 13, 2018 9:16 pm

Mon Mar 22, 2021 3:45 pm

It looks to me the USB-C PD-source mode (supplying power to a device such as your phone) works.
But the USB-C PD-sink mode (taking the power feed from a power supply) failed in someway.
Per your description, it seems to be the USB-C COntroller works in both modes, but the actual POWER-feed path failed. That is probably not easily fixed (e.g., MOSFET on-that-power-path burned.)

User avatar
Obakemono
Posts: 7
Joined: Thu Mar 11, 2021 6:58 pm

Thu Apr 08, 2021 5:02 pm

A new development here with a happy conclusion!

Once i received the USB tester i was finally able to test the Lattepanda power brick to find out that it was dead all along and i started thinking if the other power adapter they let my try at store wasn't dead/bad quality too.

I ended up ordering a decent one from amazon (Aukey Omnia 65W) aaaand it worked like a charm, it was the power adapter all along!

I'm so happy now!

Thank you for all the help.

Post Reply