[eGPU] NGFF M.2 M Key -> PCI-E 4x -> PCI-E 1x

A place to talk about all the Operating Systems, Software & Hardware
Post Reply
User avatar
figonking
Posts: 6
Joined: Fri Jan 11, 2019 7:26 am

Tue Feb 26, 2019 3:56 pm

Hi guys,

I'm setting an eGPU:
LattePanda Alpha --> A) [in] NGFF M.2 M Key [out] PCI-E 4x - -> B) [in] PCI-E 1x [out] PCI-E 16x --> C) GPU

A) https://www.amazon.co.jp/dp/B016D6NHUY
B) https://www.amazon.co.jp/dp/B077MBCSCV
C) GTX 1050Ti

it's not work, I can't install driver for graphics card.
Is it possible to setup this?

User avatar
ccs_hello
Posts: 630
Joined: Sat Oct 13, 2018 9:16 pm

Wed Feb 27, 2019 12:18 am

Please describe how you supply power (DC 12V) to GTX1050i.
This is key.
Also does your GTC1050i card itself have its own 4-pin Molex power connector? Did you supply power to it as well?

BTW, the arrangement is rather inefficient:
The first adapter it does bring out all 4 lanes of PCIe bus from the key-M M.2 slot into a regular 4x PCIe slot (which your GPU can already plug in).
The second adapter extend only one lane of the PCIe and send to the GPU card.

User avatar
ccs_hello
Posts: 630
Joined: Sat Oct 13, 2018 9:16 pm

Wed Feb 27, 2019 12:24 am

BTW, this thread should be moved to the LP Alpha subforum.

User avatar
Lutz
Posts: 214
Joined: Mon Apr 18, 2016 4:30 am
Location: Germany, NRW

Wed Feb 27, 2019 9:33 am

Moved. :)

User avatar
figonking
Posts: 6
Joined: Fri Jan 11, 2019 7:26 am

Thu Feb 28, 2019 1:05 am

Hi,

I checked my graphics card and it doesn't have private power supply pin.
This is my card: https://www.msi.com/Graphics-card/GeFor ... cification

And with this adapter: https://www.amazon.co.jp/dp/B077MBCSCV , I tried 3 times with 3 type of power pin (4 pins, 6 pins, SATA port) is separated, the graphics card's fan is working properly.

Is there any suggestion?
Thanks.

User avatar
ccs_hello
Posts: 630
Joined: Sat Oct 13, 2018 9:16 pm

Thu Feb 28, 2019 4:58 am

To simplify the situation, please only use the adapter in your post #1 part (A).
Supply 12V to that 4-pin power connector. That should be all.

BTW, the GTC1050i card you've linked has the power consumption rating of 75W. It does require a serious power supply.
(To contrast, LPA in idle state consumes about 5W.)

Also, see pictures here
https://www.lattepanda.com/topic-f23t16946.html

User avatar
figonking
Posts: 6
Joined: Fri Jan 11, 2019 7:26 am

Sun Mar 03, 2019 3:31 am

Thanks for your help.
Now I can connect my graphics card with these adapters. It's work, but looks like Window 10 is not working well with SD Bus Controller is crashed.

I removed the right side of NGFF M.2 M Key ->PCI-E 4x adapter manually, then connect the graphics card 16x and it's work.

Post Reply