[DISCUSSION] Creating image of LattePanda disk

A place to talk about all the Operating Systems, Software & Hardware
Forum rules

- Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.

- Members should post in a way which is consistent with "normal writing". That is users should not post excessive numbers of emoticons, large, small or coloured text, etc. Similarly users should not SHOUT or use excessive punctuation (e.g. ! and ?) in topic titles or posts.

- Members should use an appropriate, descriptive subject when posting a new topic. Examples of bad subjects include; "Help me!", "I'm stuck!", "I've got an error!", etc. Examples of good subjects include; "Getting an TABLE FULL error upon login", "Cannot restore a backup".

- Members are asked to post in English only so that posts can be well received and properly monitored.

- Spam is not tolerated here under any circumstance. This includes offering hosting services (charged and free), installation services, solicitation etc. Recruiting members for your own projects (moderators, designers, professional MOD work, etc.) is not permitted and is also considered spam. Users posting spam will be warned and their post removed.

- Members should post in a way that is respectful of other users. Flaming or abusing users in any way will not be tolerated and will lead to a warning. Vulgar language and inappropriate material is not allowed and will be removed. We try to maintain a family friendly atmosphere whenever it is possible within the main subject matter of this community. Please keep this in mind when participating.

- Each user is allowed to create one account. If you would like to change your username, please contact us and, most likely, we can do it for you while you can keep all of your profile data, posts, and other content.

- If a user violates our guidelines and shows a disregard for them, our staff and our community, they run the risk of losing their account. We reserve the right to deactivate any account and to edit or remove any content without warning. These guidelines are subject to change at any time without notice.

Thank you for visiting LattePanda.com!
User avatar
LattePanda
Site Admin
Posts: 2628
Joined: Wed Jan 20, 2016 9:09 am

Mon Sep 05, 2016 7:04 am

That doesn't work for me, the 'pick for a list' thing is not happening:
just tried on my lp enhanced. made yakkety yak image using rufus 2.9. 4gb micro sd in usb adapter. usb plugged in to usb3 host. pressed f7 on boot. this is the result you want. it actually booted automatically in to lubuntu when i tried.
IMG_0507.JPG
IMG_0507.JPG (1.85 MiB) Viewed 4544 times
The list shows what you can select in the bios boot order (doesn't seem to work) yet if I select the shell (since the other two choices just end up booting the LP OS) I get a list with a count down, I abort the count down by enter a key but then what? I tried help but it scrolls off the screen. I can see that fs1 is the removable device I need but mounting it does nothing.
the EFI shell shouldn't be necessary. (fyi you can scoll though the help text using pgup and pgdn)
The DOCS page refers to the fact 'it should boot' which is useless, any time there is a 'should' while describing a process there 'should' also be a statement covering what to do when 'should' doesn't happen. This is basic tech speak which does not seem to happen at LP.
i will pass this on to be rectified. thanks for your feedback.
I tried downloading the Lubuntu Yakkety Yak Image, it appears the download site is a bit overloaded, 2 hours for less than a GB? I downloaded Ubuntu x_86 desktop in 10 minutes.
this is really beyond our control.
I have the 2/32 LP so I downloaded the x_386 version, used rufus to write the image but nothing I do will make the LP boot from USB. I can take the Ubuntu 16.04 386 rufus created USB and boot from it on every PC I own but the LP.
i suspect that this might be down to a bios setting, will pass on to engineers to investigate further. have you been able to test whether usbs work within the system?
Enjoy Tinkering with LattePanda ! :lol:

User avatar
KevinA
Posts: 44
Joined: Fri Sep 02, 2016 8:54 pm

Mon Sep 05, 2016 8:35 pm

The Shell Help works with -b to pause at page boundaries but there is no: boot fs1 command, you can mount the USB drive and ls the contents. The yakkety download issue could be prevented by using Ubuntu.

I reformatted the 8GB USB drive and using Rufus placed yakkety on it, tested on a desktop then tried it in LP, fail:

Image

Test setup:

Image


Such a small device:

Image
Rufus is at 2.10.973

User avatar
KevinA
Posts: 44
Joined: Fri Sep 02, 2016 8:54 pm

Fri Sep 09, 2016 2:08 am

What I had to do after downloading Sparky x86 for the 2GB/32GB LP:
fdisk -l
/dev/mmcblk0p1 100m EFI
/dev/mmcblk0p2 16m Microsoft reserved
/dev/mmcblk0p3 28.2g Microsoft basic data
/dev/mmcblk0p4 800m Microsoft recovery environment

/dev/sda1 28.7g HPFS/NTFS USB 3.0 thumb drive
/dev/sdb1 2g Fat32 Sparky boot

sudo su
// I named the directory usb3
mkdir /mnt/usb3
chmod 755 /mnt/usb3
nano /etc/fstab
/dev/sda1 /mnt/usb3 ntfs defaults 0 1
mount /mnt/usb3
cd /mnt/usb3

dd if=/dev/mmcblk0p3 of=./mmcblk0p3.raw bs=4M status=progress
//the usb 3.0 thumb drive I purchased to do this only had 400mb left.

The above just saved the way the windows system currently is without any restore points of boot.
To get back to where you were you will have to install windows 10 from the original image and restore this dd save point BUT during the upgrade from the original windows to AE the boot sector may have changed?

If you want to back up everything you need a 32GB USB thumb drive
dd if=/dev/mmcblk0p1 | gzip > ./mmcblk0p1.gz
dd if=/dev/mmcblk0p2 | gzip > ./mmcblk0p2.gz
dd if=/dev/mmcblk0p3 | gzip > ./mmcblk0p3.gz
dd if=/dev/mmcblk0p4 | gzip > ./mmcblk0p4.gz

This gives a boot, ms reserved, data and recovery check points

gzip -dc /mnt/usb3/mmcblk0p1.gz | dd of=/dev/mmcblk0p1
gzip -dc /mnt/usb3/mmcblk0p2.gz | dd of=/dev/mmcblk0p2
gzip -dc /mnt/usb3/mmcblk0p3.gz | dd of=/dev/mmcblk0p3
gzip -dc /mnt/usb3/mmcblk0p4.gz | dd of=/dev/mmcblk0p4

User avatar
LattePanda
Site Admin
Posts: 2628
Joined: Wed Jan 20, 2016 9:09 am

Thu Mar 30, 2017 3:01 am

Thanks for your feedback
Enjoy Tinkering with LattePanda ! :lol:

Post Reply