[DISCUSSION] Linux on LattePanda

A place to talk about all the Operating Systems, Software & Hardware
Forum rules

- Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.

- Members should post in a way which is consistent with "normal writing". That is users should not post excessive numbers of emoticons, large, small or coloured text, etc. Similarly users should not SHOUT or use excessive punctuation (e.g. ! and ?) in topic titles or posts.

- Members should use an appropriate, descriptive subject when posting a new topic. Examples of bad subjects include; "Help me!", "I'm stuck!", "I've got an error!", etc. Examples of good subjects include; "Getting an TABLE FULL error upon login", "Cannot restore a backup".

- Members are asked to post in English only so that posts can be well received and properly monitored.

- Spam is not tolerated here under any circumstance. This includes offering hosting services (charged and free), installation services, solicitation etc. Recruiting members for your own projects (moderators, designers, professional MOD work, etc.) is not permitted and is also considered spam. Users posting spam will be warned and their post removed.

- Members should post in a way that is respectful of other users. Flaming or abusing users in any way will not be tolerated and will lead to a warning. Vulgar language and inappropriate material is not allowed and will be removed. We try to maintain a family friendly atmosphere whenever it is possible within the main subject matter of this community. Please keep this in mind when participating.

- Each user is allowed to create one account. If you would like to change your username, please contact us and, most likely, we can do it for you while you can keep all of your profile data, posts, and other content.

- If a user violates our guidelines and shows a disregard for them, our staff and our community, they run the risk of losing their account. We reserve the right to deactivate any account and to edit or remove any content without warning. These guidelines are subject to change at any time without notice.

Thank you for visiting LattePanda.com!
User avatar
AjSomething
Posts: 2
Joined: Sat Jan 19, 2019 7:30 pm

Fri Feb 08, 2019 7:28 pm

Update:
I found there is a bug in all 4.12 kernels I have tried. The main storage device, or more specifically /var/log is filled with useless garbage.
You will have to rename a kernel debugging mod that was enabled on accident..... [Reference Needed 1]

The "Patching " of Debian is extremely simple to accomplish.
Requirements:

1) Wired Internet connection

Steps are:
1) Edit /etc/apt/sources.list and add the following to enable "Backports"

Code: Select all

deb http://deb.debian.org/debian stretch-backports main contrib non-free
2) Run the following Commands

Code: Select all

sudo apt -t stretch-backports update
sudo apt -t stretch-backports install linux-image-4.12  [exact package name needed as of today]
3) Reboot

The Wifi will now work, Sound works, If you don't care about Bluetooth you are done... If you need bluetooth Keep going to patch the Bluetooth config files.

4) Patch Bluetooth drivers

[More Updates needed]

This has been a lot of work, It may seem easy for some but the amount of research and testing takes up alot of time. Too bad no one shows any interest in this anymore now that the new kid is on the block (Lattepanda Alpha)

User avatar
alete
Posts: 22
Joined: Thu May 19, 2016 1:58 am

Mon Oct 14, 2019 7:41 pm

Hello, little pandas! :)
I know this is an old thread but I just revived my 4gb/64gb 1st generation lattepanda and installed debian 10 'buster' with mate environment.

I'm not being able to get wifi working. Ethernet works great, but I don't even have the wifi option in the applet. What am I missing?

`uname -a` output:
Linux latte 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u1 (2019-09-20) x86_64 GNU/Linux

I also installed `linux-firmware` package just in case

User avatar
LattePanda
Site Admin
Posts: 2569
Joined: Wed Jan 20, 2016 9:09 am

Tue Oct 15, 2019 5:53 am

did you install the WIFI antennas? Can the wifi work in original Windows system?
Enjoy Tinkering with LattePanda ! :lol:

User avatar
alete
Posts: 22
Joined: Thu May 19, 2016 1:58 am

Fri Oct 18, 2019 2:35 am

LattePanda wrote:
Tue Oct 15, 2019 5:53 am
did you install the WIFI antennas? Can the wifi work in original Windows system?
Yes, and yes. Thanks.
So, to clarify, do you think I should be able to use wifi with fresh latest debian as it comes? I'll check if it's not something about the desktop environment, maybe wifi is working but I don't see it in the applet?

Thanks!!!

User avatar
sagi
Posts: 2
Joined: Thu Jan 16, 2020 10:03 am

Fri Jan 17, 2020 12:40 pm

Hi, I'm trying your image (I followed the steps from: http://docs.lattepanda.com/content/1st_ ... u-1604-lts).
I have to run Windows application on the Panda so I tried to install Wine but the installation failed.
Any way to install Wine on LattePanda Ubuntu?
Thanks!

User avatar
k3dAR
Posts: 14
Joined: Tue Jan 07, 2020 5:14 pm

Mon Jan 27, 2020 1:56 am

sagi wrote:
Fri Jan 17, 2020 12:40 pm
Hi, I'm trying your image (I followed the steps from: http://docs.lattepanda.com/content/1st_ ... u-1604-lts).
I have to run Windows application on the Panda so I tried to install Wine but the installation failed.
Any way to install Wine on LattePanda Ubuntu?
Thanks!
i'm not use image from this thread, but Xubuntu 18.04.3 64bit (installed from stock iso), when i try install wine this way: https://wiki.winehq.org/Ubuntu

is problem with missing libfaudio package, is need add another repository, howto:
https://www.linuxuprising.com/2019/09/h ... pment.html

after this is possible install package winehq-stable

working wine i confirm with install of TotalCommander...
Xubuntu 18.04 64bit @ LattePanda 2GB/4GB S70CR200-CC34E

User avatar
lovelinux
Posts: 6
Joined: Fri May 15, 2020 10:01 pm

Wed May 27, 2020 12:20 pm

Will a new version of ubuntu 16 system be released?

User avatar
lovelinux
Posts: 6
Joined: Fri May 15, 2020 10:01 pm

Tue Jun 02, 2020 8:11 am

Hi,

I installed the Linux Lite 5.0 distribution but my sound card doesn't work,
pacmd appears as 0 device in list-cards output.
How can I solve this.

Thanks

User avatar
LattePanda
Site Admin
Posts: 2569
Joined: Wed Jan 20, 2016 9:09 am

Tue Jun 02, 2020 9:49 am

lovelinux wrote:
Wed May 27, 2020 12:20 pm
Will a new version of ubuntu 16 system be released?
which Ubuntu version do you need? we released Ubuntu 16.04 for LattePanda V1.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
lovelinux
Posts: 6
Joined: Fri May 15, 2020 10:01 pm

Tue Jun 02, 2020 1:40 pm

LattePanda wrote:
Tue Jun 02, 2020 9:49 am
lovelinux wrote:
Wed May 27, 2020 12:20 pm
Will a new version of ubuntu 16 system be released?
which Ubuntu version do you need? we released Ubuntu 16.04 for LattePanda V1.
I want to continue with the current version 20.04.
My sound problem is resolved in hdmi and sound card, (Audio acpi mode On)
now only wifi problem left,
RECVbuf gives error error N does not connect to networks and works poorly

Post Reply