[DISCUSSION] Linux on LattePanda

A place to talk about all the Operating Systems, Software & Hardware
Forum rules

- Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.

- Members should post in a way which is consistent with "normal writing". That is users should not post excessive numbers of emoticons, large, small or coloured text, etc. Similarly users should not SHOUT or use excessive punctuation (e.g. ! and ?) in topic titles or posts.

- Members should use an appropriate, descriptive subject when posting a new topic. Examples of bad subjects include; "Help me!", "I'm stuck!", "I've got an error!", etc. Examples of good subjects include; "Getting an TABLE FULL error upon login", "Cannot restore a backup".

- Members are asked to post in English only so that posts can be well received and properly monitored.

- Spam is not tolerated here under any circumstance. This includes offering hosting services (charged and free), installation services, solicitation etc. Recruiting members for your own projects (moderators, designers, professional MOD work, etc.) is not permitted and is also considered spam. Users posting spam will be warned and their post removed.

- Members should post in a way that is respectful of other users. Flaming or abusing users in any way will not be tolerated and will lead to a warning. Vulgar language and inappropriate material is not allowed and will be removed. We try to maintain a family friendly atmosphere whenever it is possible within the main subject matter of this community. Please keep this in mind when participating.

- Each user is allowed to create one account. If you would like to change your username, please contact us and, most likely, we can do it for you while you can keep all of your profile data, posts, and other content.

- If a user violates our guidelines and shows a disregard for them, our staff and our community, they run the risk of losing their account. We reserve the right to deactivate any account and to edit or remove any content without warning. These guidelines are subject to change at any time without notice.

Thank you for visiting LattePanda.com!
User avatar
toxicity
Posts: 6
Joined: Thu Sep 22, 2016 12:56 pm

Sun Nov 20, 2016 3:12 pm

Yep, that is how i installed Arch Linux.

But I think the Lattepanda 4G version has a 64bit uefi, so you should be able to just use the normal Arch bootstick.

User avatar
LattePanda
Site Admin
Posts: 2570
Joined: Wed Jan 20, 2016 9:09 am

Mon Nov 21, 2016 6:45 am

merged with main linux thread.

hitting delete or escape on boot will take you to the BIOS, you can also select a boot device if you hit F7

We havent tested Windows 7 on this system but I believe it will be problematic due to the UEFI boot. We have had some success with windows 8.1. Please post results if you do make progress.

A functional Linux port is in progress and will be released shortly, but will be a debian based distro. Check out this thread

Our priority is Windows development at this time but if you make progress with Arch we would appreciate your feedback to the community. Thanks for your interest.
Enjoy Tinkering with LattePanda ! :lol:

User avatar
lunarok
Posts: 5
Joined: Sun Oct 16, 2016 12:59 pm

Fri Nov 25, 2016 4:16 pm

Have try again installing 64bits on LP32 and didn't work.
With the USB multi-arch as soon I choose 64bit install, there is only a black screen nothing else
But 32bits is ok and can be installed.

Will go for Debian, I'm used to it. But this is really annoying the UEFI 32bits

User avatar
lunarok
Posts: 5
Joined: Sun Oct 16, 2016 12:59 pm

Fri Nov 25, 2016 4:43 pm

Here : https://wiki.debian.org/UEFI#Support_for_mixed-mode_systems:_64-bit_system_with_32-bit_UEFI
Debian says 64bits detect an UEFI32bits and install right grub

So my issue is really this black screen when select 64bits

User avatar
chagui
Posts: 1
Joined: Sat Nov 26, 2016 4:35 pm

Sat Nov 26, 2016 5:02 pm

Hi guys,

just wanted to share that I finally managed a dual boot Win10 / Xubuntu 16.10. Linuxium installation on my LattePanda 64bit. WiFi (and bluetooth, I guess) is not working though.

Here are the steps:
  1. Probably not necessary, but I reinstalled Win10 following these instructions. (because I had to, after a previous unsuccessful attempt... )
  2. Download the Linuxium flavour of your taste. Xubuntu 16.10. works, I haven't tried any others.
  3. Make USB boot disk with dd (in Linux). I followed this instruction (section "For Command Line Lovers").
  4. Install Xubuntu alongside Win10.
  5. After Install, when you boot you don't get to grub, but Win10 will always start without prompting you. Even if you change the boot order in BIOS or with efibootmgr, it doesn't work.

    But then I found this:
    To solve this, simply go to Windows and open a terminal, then type the following (Need Administrative Privileges):

    Code: Select all

    bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi
    (from askubuntu.com)

    And now it works like a charm! :-)

User avatar
lunarok
Posts: 5
Joined: Sun Oct 16, 2016 12:59 pm

Mon Nov 28, 2016 10:02 am

While Debian Jessie was giving me a black screen in 64bits and cannot open X in 32bits, with Stretch it's ok
So just take the stretch mult-arch install DVD, install it on 64bits no issue, X is here with gnome in the right definition
Just missing the Wifi, will go for that package to add : firmware-brcm80211

User avatar
eccles
Posts: 2
Joined: Thu Dec 08, 2016 6:23 pm

Fri Dec 09, 2016 9:48 pm

Peppermint 7 loads easily (if somewhat slowly) & works a treat on LP.

User avatar
pccr10001
Posts: 1
Joined: Mon Dec 12, 2016 7:39 am

Tue Dec 13, 2016 9:20 am

I followed this patch to enable BCM43341 driver working on Ubuntu 16.04.1 LTS

Download

Code: Select all

unzip bcm43341.zip
cp -rf bcm43341/brcmfmac /lib/modules/4.4.0-53-generic/kernel/drivers/net/wireless/brcm80211/
cp -rf bcm43341/brcmutil /lib/modules/4.4.0-53-generic/kernel/drivers/net/wireless/brcm80211/
My kernel version

Code: Select all

Linux ubuntu 4.4.0-53-generic #74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
It's working on my LattePanda 64G/4G

User avatar
glebus
Posts: 6
Joined: Sat Dec 31, 2016 11:54 am

Sun Jan 08, 2017 11:48 am

Hi everyone!
Finaly I've got my LattePanda board!
Finaly I install Arch Linux :) (It is my firts time with UEFI :) )

BTW, good news:
http://thelinuxworks.blogspot.ru/2016/1 ... -alsa.html

I think no need to compile linux-ct anymore.

User avatar
moonshine30
Posts: 1
Joined: Thu Jan 26, 2017 9:33 am

Thu Jan 26, 2017 9:55 am

Hello Everyones !
I bought a LattePanda Enhanced, and i would like to install a linux inside.
I try to install Debian 8.7 ( the recommanded experimental version ), the Online install work's fine, but when i restart it's says that "something gone wrong" and strictly nothing happen.
So i decide to install Ubuntu server and Lubuntu ( An other recommanded version ). This times the system starts but in both of case, there is no network connections... When i do an IfConfig, i only have a loopback from de localHost ( 127.0.0.1) and when i do an ifconfig -a ; i have only one mac adress ( instead of two, one for the wifi and one for the ethernet)
Capture.JPG
Capture.JPG (52.12 KiB) Viewed 7301 times
Did anyone get this problem ? how to solve it please ?
Thanks you very much

Post Reply