[DISCUSSION] Linux on LattePanda

A place to talk about all the Operating Systems, Software & Hardware
Forum rules

- Posts are to be made in the relevant forum. Users are asked to read the forum descriptions before posting.

- Members should post in a way which is consistent with "normal writing". That is users should not post excessive numbers of emoticons, large, small or coloured text, etc. Similarly users should not SHOUT or use excessive punctuation (e.g. ! and ?) in topic titles or posts.

- Members should use an appropriate, descriptive subject when posting a new topic. Examples of bad subjects include; "Help me!", "I'm stuck!", "I've got an error!", etc. Examples of good subjects include; "Getting an TABLE FULL error upon login", "Cannot restore a backup".

- Members are asked to post in English only so that posts can be well received and properly monitored.

- Spam is not tolerated here under any circumstance. This includes offering hosting services (charged and free), installation services, solicitation etc. Recruiting members for your own projects (moderators, designers, professional MOD work, etc.) is not permitted and is also considered spam. Users posting spam will be warned and their post removed.

- Members should post in a way that is respectful of other users. Flaming or abusing users in any way will not be tolerated and will lead to a warning. Vulgar language and inappropriate material is not allowed and will be removed. We try to maintain a family friendly atmosphere whenever it is possible within the main subject matter of this community. Please keep this in mind when participating.

- Each user is allowed to create one account. If you would like to change your username, please contact us and, most likely, we can do it for you while you can keep all of your profile data, posts, and other content.

- If a user violates our guidelines and shows a disregard for them, our staff and our community, they run the risk of losing their account. We reserve the right to deactivate any account and to edit or remove any content without warning. These guidelines are subject to change at any time without notice.

Thank you for visiting LattePanda.com!
User avatar
Site Admin
Posts: 2569
Joined: Wed Jan 20, 2016 9:09 am

Thu Mar 30, 2017 2:41 am

I used a LP 4GB with Ubuntu 16.04 LTS and no drivers were required.

BIOS settings that I changed:
Force lid status (as I mentioned above)

Code: Select all

chipset > south bridge > LPSS & SCC configuration > SCC SDIO support
When using Ubuntu it was configured as dual monitor working out of the box, with an HDMI display as the secondary display, so I disabled the MIPI to force it to a primary display.

Actually I have experimented with a Lubuntu live disk before and it was the same situation, working out of the box. Sorry it's not really a solution, I can only relay my experiences. Perhaps someone else might be able to shed some light on this...
Enjoy Tinkering with LattePanda ! :lol:

User avatar
Posts: 22
Joined: Thu May 19, 2016 1:58 am

Sat Apr 01, 2017 10:48 pm

I decided to reinstall win10 and then give a try to Debian on LP. Installation went fine.
This version:
http://cdimage.debian.org/pub/debian-cd ... ch/iso-cd/
(as suggested in forum (experimental): http://www.lattepanda.com/forum/viewtopic.php?f=5&t=275 )
at the moment I was about to change the boot from windows:

Code: Select all

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi
I noticed that it was for ubuntu and maybe i would screw everything up. So I decided to boot debian FROM BIOS SETUP in order to browse grub files to check what path I should use.

Well, it seems like something went wrong somewhere because I cannot even boot debian:
[LP screen photo]: http://imgur.com/a/oy3nd

User avatar
Posts: 8
Joined: Wed Dec 21, 2016 1:40 am

Tue Apr 04, 2017 6:34 pm

This will serve to confirm the posting by lattepanda_lover on Wed Mar 15, 2017 at 7:45 pm . I am using a 4-64 unit running 64 bit software. :)

I have been using his version of Ubuntu: ( https://goo.gl/ePa3Nd) for a couple weeks now with no significant issues.

The only known non-functional item is Bluetooth. (I tried the moderator posting. Didn’t work for me. Maybe the Linuxium patches made it incompatible?)

1.) HDMI video and audio work fine.
2.) By selecting the correct display from settings, all but the most minor traces of cursor and display stability have vanished.
3.) USB is fully functional, both 2 & 3.
4.) The micro SD card slot works fine as long as you leave a card in it when you boot the LattePanda. Don’t forget the previously posted bios tweak: South Bridge>LPSS & SCC Configuration > SCC SD Card Support > PCI
5.) WIFi works fine on both high and low bands. I’m currently using the LattePanda on the upper end of the 5Ghz band with no known issues.
6.) No known issue with the wired network jack.
7.) I have setup and been using Samba with a networked Windows 7 computer and can both transfer and play files remotely on the windows machine.
8.) I have setup and used my Windows 98 vintage scanner (Microtek ScanMaker X6) with no known issues. (Simple Scan and Xsane both work.)
9.) I have used an USB DVD player connected directly to the LattePanda to play DVDs with no issues. (I’m fond of VLC here.)

I had previously experimented with Xubuntu 16.04.2 and 17.04 Beta 1 Versions from Linuxium. I never could get the notification area to display. (It was grayed out in the Panel Customization area in Xubuntu. Loads but does not display.) I was also having screen stability issues (ghosting cursors) and both wired and wireless networking was dropping Flash videos.

I have not tried the 17.04 Beta 1 Unity version of Ubuntu form Linuxium. We’re so close to the formal release of 17.04 (April 13th.), I decided I’d wait to get out of Beta before giving it another shot. (Obviously Linuxium will need a few days to put in the necessary patches.)

Thermal issues: Using my dual fan approach, https://youtu.be/oSE7_Hd6vEs my Latte Panda boots at about 40-42C and then settles out and runs at 31-34C. (House is at 22C.) I have noted no thermal, issues with the unit using this approach. :lol:

User avatar
Posts: 1
Joined: Thu Feb 09, 2017 8:48 am

Wed Apr 05, 2017 7:15 pm

Has anyone managed to make the touchscreen work on linux?

User avatar
Posts: 22
Joined: Thu May 19, 2016 1:58 am

Sun Apr 09, 2017 8:36 pm

After trying with the debian version that is suggested in the forum here:
that is:
http://cdimage.debian.org/pub/debian-cd ... ch/iso-cd/
and failed,( https://imgur.com/a/oy3nd ) I tried another one by browsing in debian's web site:
http://cdimage.debian.org/debian-cd/cur ... etinst.iso

It boots, but until now I can't make the SD card to work. I've already changed the suggested value in BIOS
Don’t forget the previously posted bios tweak: South Bridge>LPSS & SCC Configuration > SCC SD Card Support > PCI
Any advice would be appreciated.

User avatar
Posts: 14
Joined: Sun Oct 30, 2016 8:02 pm

Thu Apr 13, 2017 12:34 pm

Hello All,

Thank you for all your contributions to this thread, it really is a great example of the power of community development to solve a problem.

However, some of the information in this thread is now outdated; early hacks are now replaced by kernel improvements in recent linux releases. We need a statement of where development currently is, and what the current recommended method of installation is.

My understanding is that, as of this point, the LP mostly works (with the exception of the Arduino connectivity and bluetooth) on a Linuxium-modified version of Ubuntu. Is this correct? Also, vis-a-vis mainline Ubuntu development, will these be incorporated into regular Ubuntu in 17.04 or 17.10? That is, if we wait for 17.04, will a vanilla Ubuntu install work without issues?

Could someone with a history of involvement with this thread please give a quick summary of -

1) What the current best (ie easiest) method of installing a *buntu distro on the LP is
2) What is NOT working if (1) above is followed
3) Whether waiting for 17.04 or 17.10 releases will bring plug-n-play functionality to the LP on linux.



User avatar
Posts: 8
Joined: Wed Dec 21, 2016 1:40 am

Fri Apr 14, 2017 6:03 pm

What I know works using Ubuntu on a LattePanda 4-64.

I can only speak for 64 bit software on a 4-64 unit.

I have not tried Arduino, but software from Arduino's website should be available for download.

I have not tested Ubuntu 17.04 Unity Desktop. I tried Xubuntu and Lubuntu in the 17.04 Linuxium releases. Both had menu /notification issues and ghosting cursors.

Ubuntu 17.04 has been released in a unpatched form. I'm just waiting on Linuxium to release it's patched version before updating.

ONLY Ubuntu 16.04.2 in the Unity Desktop works. XUbuntu does NOT work. (Missing Notification area.) I can only speak for HDMI which works fine. Both high and low band wireless work fine. Wired network works. The micro SD card works if you boot with a card in place. (The bios trick is required. See my last post.) USB works. Bluetooth does not work.

To answer Scrappyjoe directly:
1.) Ubuntu Unity Desktop16.04.2 Linuxium patched version. I've been using it for a couple weeks.
2.) Bluetooth is the only thing I know of.
3.) One can only hope. Linuxium sounds positive. That is all we know for now. Linuxium has stated some Cherry Trail functionality may be included in the 4.11 Kernel. That means mainline kernel functionality may come with the 17.10 Ubuntu release. Way to early to tell. Some other Bay/Cherry Trail devices have working Broadcom Bluetooth. They might be using different chips.

User avatar
Posts: 14
Joined: Sun Oct 30, 2016 8:02 pm

Wed Apr 19, 2017 9:15 pm

Thanks for the comprehensive update edhumble! Good to see where we stand. It's a real pity - I think Xubuntu would perfect. Ah well, wait and see.

User avatar
Posts: 2
Joined: Wed Mar 22, 2017 9:13 pm

Sat Apr 22, 2017 2:35 pm


Is there a way to reset the BIOS to factory default without accessing the BIOS? I made a change in the BIOS a while back and now I have forgotten what I changed. The problem is, no USB device is now working, so I am unable to get the BIOS because the keyboard is not working.

User avatar
Posts: 22
Joined: Thu May 19, 2016 1:58 am

Thu Apr 27, 2017 12:52 am

Npinon wrote:Has anyone managed to make the touchscreen work on linux?
I did. Just installed debian test, and touchpad works, straightforward.

Post Reply